redirecting OSC through VLAN does not work

#1
Hi all
i have a server and a client running on linux 16.04

i have made 2 VLAN's one for control (where a lot of other equipment is in the same network)
and one for OSC only with only clients and servers.
in the config file of the server i disabled send to amcp-clients to avoid that the server would
sendout osc on the control network.

and made predifined OSC clients into the OSC vlan with port destination 7250
when i look to the bindings on the client side (with "lsof") i see this

Code: Select all

lsof -Pnl +M -i4
COMMAND    PID     USER   FD   TYPE DEVICE SIZE/OFF NODE NAME

shell     7867     1000   14u  IPv4  72619      0t0  TCP 192.168.50.100:55188->192.168.50.10:5250 (ESTABLISHED)
shell     7867     1000   15u  IPv4  72620      0t0  UDP *:7250 
and changed the OSC input on the client side to port 7250
but no OSC shows up in the client.
when i start netcat to listen on port 7250 i do see osc data coming in !
and when i "lsof" then i see this

Code: Select all

lsof -Pnl +M -i4
COMMAND    PID     USER   FD   TYPE DEVICE SIZE/OFF NODE NAME

shell     7867     1000   14u  IPv4  72619      0t0  TCP 192.168.50.100:55188->192.168.50.10:5250 (ESTABLISHED)
shell     7867     1000   15u  IPv4  72620      0t0  UDP *:7250 
nc        8175     1000    3u  IPv4  74534      0t0  UDP 192.168.51.100:7250->192.168.51.10:58598
which looks correct to me. the *:7250 is binding the client to all interfaces or is this a wrong conclusion ?

by the way my server has ip 192.168.50.10/24 for control and 192.168.51.10/24 for osc
and the client is on
192.168.50.100/24 and 192.168.51.100/24

am i doing something wrong ?? or is the client not really binding to all interfaces ?

ls
Maurice

Who is online

Users browsing this forum: No registered users and 1 guest

cron