Decklink failing to load

#1
Sometimes decklink fails to load - any ideas ?

I get some warnings at start up like:

Code: Select all

[2017-09-11 10:17:06.362] [6948] [warning] Device does not support video-format: 1080i50
When it fails the log says

Code: Select all

[2017-09-11 16:38:02.372] [4540] [info]    Received message from 127.0.0.1: MIXER 1 CLEAR\r\n
[2017-09-11 16:38:02.373] [4540] [info]    Received message from 127.0.0.1: CLEAR 1\r\n
[2017-09-11 16:38:02.373] [5976] [info]    Sent message to 127.0.0.1:202 MIXER OK\r\n
[2017-09-11 16:38:02.373] [4540] [info]    Received message from 127.0.0.1: LOAD 1-11 INTRO\r\n
[2017-09-11 16:38:02.373] [5976] [info]    Sent message to 127.0.0.1:202 CLEAR OK\r\n
[2017-09-11 16:38:02.373] [4540] [info]    Received message from 127.0.0.1: LOAD 1-10 DECKLINK DEVICE 3 FORMAT 1080i5000\r\n
[2017-09-11 16:38:02.373] [4540] [info]    Received message from 127.0.0.1: LOAD 1-9 DECKLINK DEVICE 4 FORMAT 1080i5000\r\n
[2017-09-11 16:38:02.374] [4540] [info]    Received message from 127.0.0.1: CLS\r\n
[2017-09-11 16:38:02.377] [1260] [info]    Sent message to 127.0.0.1:200 CLS OK\r\n"12BUND" MOVIE 43997397 20170911093802 1086 1/25\r\n"17BUND" MOVIE 75275150 20170911135942 1854 1/25\r\n"19BUND" MOVIE 286814082 20170905135850 7101 1/25\r\n"BUND" MOVIE 140302204 20170905135852 3463 1/25\r\n"INTRO" MOVIE 8445701 20170905135852 203 1/25\r\n"OUTRO" MOVIE 5872909 20170905135852 143 1/25\r\n"VEJRET" MOVIE 33238272 20170905135852 810 1/25\r\n"VEJRINTRO" MOVIE 8317186 20170905135853 194 1/25\r\n"VEJROUTRO" MOVIE 7851720 20170905135853 186 1/25\r\n\r\n
[2017-09-11 16:38:02.408] [6100] [info]    ffmpeg[Intro.mp4|1920x1080p25.00|2/203] Destroyed.
[2017-09-11 16:38:02.418] [5976] [info]    ffmpeg[Intro.mp4|1920x1080p25.00|0/203] [video-decoder] H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
[2017-09-11 16:38:02.422] [5976] [info]    ffmpeg[Intro.mp4|1920x1080p25.00|0/203] [audio-decoder] AAC (Advanced Audio Coding)
[2017-09-11 16:38:02.424] [5976] [info]    Sent message to 127.0.0.1:202 LOAD OK\r\n
[2017-09-11 16:38:02.480] [6528] [info]    [frame_muxer] simple 1920x1080p25.00
[2017-09-11 16:38:02.539] [6100] [info]    DeckLink SDI [3|1080i5000] Destroyed.
[2017-09-11 16:38:02.546] [5976] [error]   modules\decklink\producer\decklink_producer.cpp(165): Throw in function __cdecl caspar::decklink::decklink_producer::decklink_producer(const struct caspar::core::video_format_desc &,int,const class caspar::spl::shared_ptr<class caspar::core::frame_factory> &,const struct caspar::core::video_format_desc &,const struct caspar::core::audio_channel_layout &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &)
[2017-09-11 16:38:02.546] [5976] [error]   Dynamic exception type: class boost::exception_detail::clone_impl<struct caspar::caspar_exception>
[2017-09-11 16:38:02.546] [5976] [error]   [struct boost::errinfo_api_function_ * __ptr64] = EnableVideoInput
[2017-09-11 16:38:02.546] [5976] [error]   [struct caspar::tag_call_stack_info * __ptr64] = 
[2017-09-11 16:38:02.546] [5976] [error]       modules\decklink\producer\decklink_producer.cpp (163): caspar::decklink::decklink_producer::decklink_producer
[2017-09-11 16:38:02.546] [5976] [error]       modules\decklink\producer\decklink_producer.cpp (374): <lambda_1466ee673ed750a35c6af4909a11c70c>::operator()
[2017-09-11 16:38:02.546] [5976] [error]       functional (209): std::_Func_impl<<lambda_a6dbc74b45a218995f9662e8efb84a49>,std::allocator<int>,void>::_Do_call
[2017-09-11 16:38:02.546] [5976] [error]       future (750): std::_Packaged_state<void __cdecl(void)>::_Call_immediate
[2017-09-11 16:38:02.546] [5976] [error]       common\executor.h (234): <lambda_19ec9768eaa7116b7189e1e21ee61a00>::operator()
[2017-09-11 16:38:02.546] [5976] [error]       common\executor.h (286): caspar::executor::run
[2017-09-11 16:38:02.546] [5976] [error]       000000013FBAA413 (casparcg): (filename not available): boost::detail::shared_count::swap
[2017-09-11 16:38:02.546] [5976] [error]       000007FEF698BE1D (ucrtbase): (filename not available): crt_at_quick_exit
[2017-09-11 16:38:02.546] [5976] [error]       00000000773159CD (kernel32): (filename not available): BaseThreadInitThunk
[2017-09-11 16:38:02.546] [5976] [error]       000000007744A561 (ntdll): (filename not available): RtlUserThreadStart
[2017-09-11 16:38:02.546] [5976] [error]   
[2017-09-11 16:38:02.546] [5976] [error]   [struct caspar::tag_context_info * __ptr64] = 
[2017-09-11 16:38:02.546] [5976] [error]   [struct caspar::tag_msg_info * __ptr64] = DeckLink SDI [3|1080i5000] Could not enable video input.
[2017-09-11 16:38:02.546] [5976] [error]   Caught at (AMCPCommandQueue Channel 1 for TCP Port 5250):
[2017-09-11 16:38:02.546] [5976] [error]   
[2017-09-11 16:38:02.546] [5976] [error]       core\producer\frame_producer.cpp (331): `<lambda_0b473c66a9e2f34723aac9f98f1fd7bd>::operator()'::`1'::catch$2
[2017-09-11 16:38:02.546] [5976] [error]       000007FEF6A3C220 (VCRUNTIME140): (filename not available): _C_specific_handler
[2017-09-11 16:38:02.546] [5976] [error]       000007FEF6A329B2 (VCRUNTIME140): (filename not available): _FrameUnwindFilter
[2017-09-11 16:38:02.546] [5976] [error]       000000007746B681 (ntdll): (filename not available): RtlRestoreContext
[2017-09-11 16:38:02.546] [5976] [error]       core\producer\frame_producer.cpp (320): <lambda_0b473c66a9e2f34723aac9f98f1fd7bd>::operator()
[2017-09-11 16:38:02.546] [5976] [error]       core\producer\frame_producer.cpp (316): caspar::core::do_create_producer
[2017-09-11 16:38:02.546] [5976] [error]       core\producer\frame_producer.cpp (382): caspar::core::frame_producer_registry::create_producer
[2017-09-11 16:38:02.546] [5976] [error]       protocol\amcp\amcpcommandsimpl.cpp (434): caspar::protocol::amcp::load_command
[2017-09-11 16:38:02.546] [5976] [error]       type_traits (1408): std::_Invoker_functor::_Call<std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t> > (__cdecl*& __ptr64)(caspar::protocol::amcp::command_context & __ptr64),caspar::protocol::amcp::command_context & __ptr64>
[2017-09-11 16:38:02.546] [5976] [error]       type_traits (1476): std::invoke<std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t> > (__cdecl*& __ptr64)(caspar::protocol::amcp::command_context & __ptr64),caspar::protocol::amcp::command_context & __ptr64>
[2017-09-11 16:38:02.546] [5976] [error]       type_traits (1501): std::_Invoke_ret<std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t> >,std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t> > (__cdecl*& __ptr64)(caspar::protocol::amcp::command_context & __ptr64),caspar::protocol::amcp::command_context & __ptr64>
[2017-09-11 16:38:02.546] [5976] [error]       functional (209): std::_Func_impl<std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t> > (__cdecl*)(caspar::protocol::amcp::command_context & __ptr64),std::allocator<int>,std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t> >,caspar::protocol::amcp::command_context & __ptr64>::_Do_call
[2017-09-11 16:38:02.546] [5976] [error]       functional (275): std::_Func_class<std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t> >,caspar::protocol::amcp::command_context & __ptr64>::operator()
[2017-09-11 16:38:02.546] [5976] [error]       protocol\amcp\amcpcommand.h (112): caspar::protocol::amcp::AMCPCommand::Execute
[2017-09-11 16:38:02.546] [5976] [error]       protocol\amcp\amcpcommandqueue.cpp (106): <lambda_b146f9aee8aafa4989577d7a50b08cf3>::operator()
[2017-09-11 16:38:02.546] [5976] [error]       functional (209): std::_Func_impl<<lambda_adcc1d275de643d3997d4548168c1475>,std::allocator<int>,void>::_Do_call
[2017-09-11 16:38:02.546] [5976] [error]       future (750): std::_Packaged_state<void __cdecl(void)>::_Call_immediate
[2017-09-11 16:38:02.546] [5976] [error]       common\executor.h (234): <lambda_66f462db7b216ba64b393bcbfd7112a8>::operator()
[2017-09-11 16:38:02.546] [5976] [error]       common\executor.h (286): caspar::executor::run
[2017-09-11 16:38:02.546] [5976] [error]       000000013FBAA413 (casparcg): (filename not available): boost::detail::shared_count::swap
[2017-09-11 16:38:02.546] [5976] [error]       000007FEF698BE1D (ucrtbase): (filename not available): crt_at_quick_exit
[2017-09-11 16:38:02.546] [5976] [error]       00000000773159CD (kernel32): (filename not available): BaseThreadInitThunk
[2017-09-11 16:38:02.546] [5976] [error]       000000007744A561 (ntdll): (filename not available): RtlUserThreadStart
[2017-09-11 16:38:02.546] [5976] [error]   
[2017-09-11 16:38:02.560] [5976] [error]   No match found for supplied commands. Check syntax. Turn on log level debug for stacktrace.
[2017-09-11 16:38:02.560] [5976] [info]    Sent message to 127.0.0.1:404 LOAD FAILED\r\n
[2017-09-11 16:38:02.616] [6100] [info]    DeckLink SDI [4|1080i5000] Destroyed.
[2017-09-11 16:38:02.979] [3788] [info]    [frame_muxer] simple 1920x1080i50.00
[2017-09-11 16:38:02.982] [5256] [info]    DeckLink SDI [4|1080i5000] Initialized
[2017-09-11 16:38:02.984] [5976] [info]    Sent message to 127.0.0.1:202 LOAD OK\r\n
[2017-09-11 16:38:57.692] [4540] [info]    Received message from 127.0.0.1: REQ Intro PLAY 1-11 Intro MIX 6\r\n
[2017-09-11 16:38:57.692] [4540] [info]    Received message from 127.0.0.1: LOADBG 1-11 EMPTY MIX 6 AUTO\r\n
Log from startup

Code: Select all

2017-09-11 10:17:03.699] [1220] [info]    Starting CasparCG Video and Graphics Playout Server 2.1.0.3437 dc2e94b Beta 2
[2017-09-11 10:17:03.699] [1220] [info]    on Windows 7 Enterprise Service Pack 1
[2017-09-11 10:17:03.699] [1220] [info]    Intel(R) Xeon(R) CPU E5-1620 v3 @ 3.50GHz Physical Threads: 8
[2017-09-11 10:17:03.699] [1220] [info]    HP Z440 Workstation
[2017-09-11 10:17:03.700] [1220] [info]    Initialized reroute module.
[2017-09-11 10:17:03.702] [1220] [info]    Initialized ffmpeg module.
[2017-09-11 10:17:03.702] [1220] [info]    Initialized oal module.
[2017-09-11 10:17:05.283] [1220] [info]    Initialized bluefish module.
[2017-09-11 10:17:05.283] [1220] [info]    Initialized decklink module.
[2017-09-11 10:17:05.283] [1220] [info]    Initialized screen module.
[2017-09-11 10:17:05.348] [1220] [info]    Initialized html module.
[2017-09-11 10:17:05.348] [1220] [info]    Initialized psd module.
[2017-09-11 10:17:05.530] [1220] [info]    Initialized flash module.
[2017-09-11 10:17:05.530] [1220] [info]    Initialized newtek module.
[2017-09-11 10:17:05.530] [1220] [info]    Initialized image module.
[2017-09-11 10:17:05.752] [1220] [info]    ffmpeg.avcodec 56.41.100
[2017-09-11 10:17:05.752] [1220] [info]    ffmpeg.avformat 56.36.100
[2017-09-11 10:17:05.752] [1220] [info]    ffmpeg.avfilter 5.16.101
[2017-09-11 10:17:05.753] [1220] [info]    ffmpeg.avutil 54.27.100
[2017-09-11 10:17:05.753] [1220] [info]    ffmpeg.swscale 3.1.101
[2017-09-11 10:17:05.753] [1220] [info]    bluefish.version Not found
[2017-09-11 10:17:05.753] [1220] [info]    decklink.version 10.4.1
[2017-09-11 10:17:05.753] [1220] [info]    decklink.device DeckLink SDI [1]
[2017-09-11 10:17:05.753] [1220] [info]    decklink.device DeckLink SDI [2]
[2017-09-11 10:17:05.753] [1220] [info]    decklink.device DeckLink SDI [3]
[2017-09-11 10:17:05.753] [1220] [info]    decklink.device DeckLink SDI [4]
[2017-09-11 10:17:05.753] [1220] [info]    cef.version 3.1750.1805
[2017-09-11 10:17:05.753] [1220] [info]    cef.chromeversion 33.0.1750.170
[2017-09-11 10:17:05.754] [1220] [info]    flash 11.8.800.94
[2017-09-11 10:17:05.754] [1220] [info]    newtek-ivga.version unavailable (Processing.AirSend.x64.dll)
[2017-09-11 10:17:05.754] [1220] [info]    freeimage 3.16.0
[2017-09-11 10:17:05.754] [1220] [info]    casparcg.config:
[2017-09-11 10:17:05.754] [1220] [info]    -----------------------------------------
[2017-09-11 10:17:05.754] [1220] [info]    <?xml version="1.0" encoding="utf-8"?>
[2017-09-11 10:17:05.754] [1220] [info]    <configuration>
[2017-09-11 10:17:05.754] [1220] [info]       <paths>
[2017-09-11 10:17:05.754] [1220] [info]          <media-path>media/</media-path>
[2017-09-11 10:17:05.754] [1220] [info]          <log-path>log/</log-path>
[2017-09-11 10:17:05.754] [1220] [info]          <data-path>data/</data-path>
[2017-09-11 10:17:05.754] [1220] [info]          <template-path>template/</template-path>
[2017-09-11 10:17:05.754] [1220] [info]          <thumbnail-path>thumbnail/</thumbnail-path>
[2017-09-11 10:17:05.754] [1220] [info]          <font-path>font/</font-path>
[2017-09-11 10:17:05.754] [1220] [info]       </paths>
[2017-09-11 10:17:05.754] [1220] [info]       <thumbnails>
[2017-09-11 10:17:05.754] [1220] [info]          <width>256</width>
[2017-09-11 10:17:05.754] [1220] [info]          <height>144</height>
[2017-09-11 10:17:05.754] [1220] [info]          <video-grid>1</video-grid>
[2017-09-11 10:17:05.754] [1220] [info]          <video-mode>1080i5000</video-mode>
[2017-09-11 10:17:05.754] [1220] [info]       </thumbnails>
[2017-09-11 10:17:05.754] [1220] [info]       <lock-clear-phrase>secret</lock-clear-phrase>
[2017-09-11 10:17:05.754] [1220] [info]       <channels>
[2017-09-11 10:17:05.754] [1220] [info]          <channel>
[2017-09-11 10:17:05.754] [1220] [info]             <video-mode>1080i5000</video-mode>
[2017-09-11 10:17:05.754] [1220] [info]             <channel-layout>stereo</channel-layout>
[2017-09-11 10:17:05.754] [1220] [info]             <consumers>
[2017-09-11 10:17:05.754] [1220] [info]                <decklink>
[2017-09-11 10:17:05.754] [1220] [info]                   <device>1</device>
[2017-09-11 10:17:05.754] [1220] [info]                   <keyer>internal</keyer>
[2017-09-11 10:17:05.754] [1220] [info]                   <embedded-audio>true</embedded-audio>
[2017-09-11 10:17:05.754] [1220] [info]                </decklink>
[2017-09-11 10:17:05.754] [1220] [info]             </consumers>
[2017-09-11 10:17:05.754] [1220] [info]          </channel>
[2017-09-11 10:17:05.754] [1220] [info]          <channel>
[2017-09-11 10:17:05.754] [1220] [info]             <video-mode>1080i5000</video-mode>
[2017-09-11 10:17:05.754] [1220] [info]             <channel-layout>stereo</channel-layout>
[2017-09-11 10:17:05.754] [1220] [info]             <system-audio/>
[2017-09-11 10:17:05.754] [1220] [info]             <consumers>
[2017-09-11 10:17:05.754] [1220] [info]                <decklink>
[2017-09-11 10:17:05.754] [1220] [info]                   <device>2</device>
[2017-09-11 10:17:05.754] [1220] [info]                   <keyer>internal</keyer>
[2017-09-11 10:17:05.754] [1220] [info]                   <embedded-audio>true</embedded-audio>
[2017-09-11 10:17:05.754] [1220] [info]                </decklink>
[2017-09-11 10:17:05.754] [1220] [info]                <system-audio/>
[2017-09-11 10:17:05.754] [1220] [info]             </consumers>
[2017-09-11 10:17:05.754] [1220] [info]          </channel>
[2017-09-11 10:17:05.754] [1220] [info]       </channels>
[2017-09-11 10:17:05.754] [1220] [info]       <controllers>
[2017-09-11 10:17:05.754] [1220] [info]          <tcp>
[2017-09-11 10:17:05.754] [1220] [info]             <port>5250</port>
[2017-09-11 10:17:05.754] [1220] [info]             <protocol>AMCP</protocol>
[2017-09-11 10:17:05.754] [1220] [info]          </tcp>
[2017-09-11 10:17:05.754] [1220] [info]          <tcp>
[2017-09-11 10:17:05.754] [1220] [info]             <port>3250</port>
[2017-09-11 10:17:05.754] [1220] [info]             <protocol>LOG</protocol>
[2017-09-11 10:17:05.754] [1220] [info]          </tcp>
[2017-09-11 10:17:05.754] [1220] [info]       </controllers>
[2017-09-11 10:17:05.754] [1220] [info]    </configuration>
[2017-09-11 10:17:05.754] [1220] [info]    -----------------------------------------
[2017-09-11 10:17:05.755] [1220] [info]    Initialized audio config.
[2017-09-11 10:17:05.756] [1220] [info]    Initializing OpenGL Device.
[2017-09-11 10:17:06.066] [1220] [info]    Successfully initialized OpenGL 4.5.0 NVIDIA 376.09 NVIDIA Corporation
[2017-09-11 10:17:06.069] [1220] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 1
[2017-09-11 10:17:06.070] [1220] [info]    video_channel[1|1080i5000] Successfully Initialized.
[2017-09-11 10:17:06.070] [1220] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 2
[2017-09-11 10:17:06.070] [1220] [info]    video_channel[2|1080i5000] Successfully Initialized.
[2017-09-11 10:17:06.214] [6736] [warning] Device does not support video-format: 1080i50
[2017-09-11 10:17:06.215] [6736] [info]    DeckLink SDI [1-1|1080i5000] Enabled embedded-audio.
[2017-09-11 10:17:06.215] [6736] [info]    DeckLink SDI [1-1|1080i5000] Disabled low-latency mode.
[2017-09-11 10:17:06.216] [6736] [info]    DeckLink SDI [1-1|1080i5000] Enabled internal keyer.
[2017-09-11 10:17:06.283] [1220] [info]    DeckLink SDI [1-1|1080i5000] Initialized.
[2017-09-11 10:17:06.362] [6948] [warning] Device does not support video-format: 1080i50
[2017-09-11 10:17:06.363] [6948] [info]    DeckLink SDI [2-2|1080i5000] Enabled embedded-audio.
[2017-09-11 10:17:06.363] [6948] [info]    DeckLink SDI [2-2|1080i5000] Disabled low-latency mode.
[2017-09-11 10:17:06.364] [6948] [info]    DeckLink SDI [2-2|1080i5000] Enabled internal keyer.
[2017-09-11 10:17:06.427] [6492] [info]    DeckLink SDI [1-1|1080i5000] Reference signal: locked.
[2017-09-11 10:17:06.459] [1220] [info]    DeckLink SDI [2-2|1080i5000] Initialized.
[2017-09-11 10:17:06.498] [1220] [info]    oal[2|1080i5000] Initialized.
[2017-09-11 10:17:06.498] [1220] [info]    Initialized channels.
[2017-09-11 10:17:06.498] [1220] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 0
[2017-09-11 10:17:06.499] [1220] [info]    Initialized thumbnail generator.
[2017-09-11 10:17:06.501] [1220] [info]    Initialized controllers.
[2017-09-11 10:17:06.501] [1220] [info]    Initialized osc.
[2017-09-11 10:17:06.502] [1220] [info]    Started initial media information retrieval.
[2017-09-11 10:17:06.587] [4844] [info]    DeckLink SDI [2-2|1080i5000] Reference signal: locked.
[2017-09-11 10:17:06.951] [7124] [info]    Initial media information retrieval finished.

Re: Decklink failing to load

#4
I never investigated any further, as the machine is running in production, but I would say that what I discovered would be a hardware problem. If I remember correctly the device wasn't showing up decklink software either.
CasparCG enthusiast and broadcast geek
cron