It is currently 28 Jun 2017, 20:19



Fullscreen Playback of YouTube live streams

Videos, graphics, Flash templates – how to create and play them using CasparCG

Moderators: Macey, Jonas Hummelstrand, didikunz

Fullscreen Playback of YouTube live streams

Postby Theo » 25 Jan 2016, 11:54

Hi,
I'm trying to play Youtube live streams with this command
PLAY 1-1 [HTML] "https://www.youtube.com/embed/D_vDTd-qxeg"

This is the embed code from the youtube player and lets Casper open a fullscreen window of the stream.
This works but doesnot start the stream.
How can I (auto) start the stream?
Regards,
Theo Kooijmans
UniversalDV
User avatar
Theo
 
Posts: 92
Joined: 03 Jun 2012, 10:44
Location: The Netherlands

Re: Fullscreen Playback of YouTube live streams

Postby vimlesh1975 » 25 Jan 2016, 12:56

add "?autoplay=true" at the end of the url
Code: Select all
PLAY 1-1 [HTML] "https://www.youtube.com/embed/D_vDTd-qxeg?autoplay=true"
User avatar
vimlesh1975
 
Posts: 603
Joined: 29 Aug 2011, 11:42
Location: Doordarshan, Mumbai, India

Re: Fullscreen Playback of YouTube live streams

Postby Theo » 25 Jan 2016, 14:23

Super Thanks!
Regards,
Theo Kooijmans
UniversalDV
User avatar
Theo
 
Posts: 92
Joined: 03 Jun 2012, 10:44
Location: The Netherlands

Re: Fullscreen Playback of YouTube live streams

Postby Theo » 25 Jan 2016, 14:42

Hi Vimlesh,
This works great!,
Is it possible to get the audio of the stream also out through the Decklinkcard?
I have everything setup and working with clip playout to go through the Decklinkcard...
Regards,
Theo Kooijmans
UniversalDV
User avatar
Theo
 
Posts: 92
Joined: 03 Jun 2012, 10:44
Location: The Netherlands

Re: Fullscreen Playback of YouTube live streams

Postby vimlesh1975 » 25 Jan 2016, 16:30

In pc setting, Set default audio playback device as decklink.
User avatar
vimlesh1975
 
Posts: 603
Joined: 29 Aug 2011, 11:42
Location: Doordarshan, Mumbai, India

Re: Fullscreen Playback of YouTube live streams

Postby Theo » 29 Jan 2016, 18:25

Hi Vimlesh,
The audio plays fine with the decklinkcard is set a default audio device.
Audio is however badly offsync, audio is about 1sec early, any tricks for that?
Regards,
Theo Kooijmans
UniversalDV
User avatar
Theo
 
Posts: 92
Joined: 03 Jun 2012, 10:44
Location: The Netherlands

Re: Fullscreen Playback of YouTube live streams

Postby tracypeterson » 24 Feb 2016, 02:25

I've noticed that the youtube playback is not synched and that the audio does not stop if you stop the video before it's over.

Submit a bug report :)
tracypeterson
 
Posts: 41
Joined: 28 Jun 2014, 10:11

Re: Fullscreen Playback of YouTube live streams

Postby Swordh » 13 Mar 2016, 23:26

Isn't it easier to just download the clip first? you'll get rid of buffering and a more reliable source.
youtube-dl is a great tool for doing this.
Swordh
 
Posts: 12
Joined: 20 Oct 2014, 15:20

Re: Fullscreen Playback of YouTube live streams

Postby didikunz » 13 Mar 2016, 23:30

Swordh wrote:Isn't it easier to just download the clip first? you'll get rid of buffering and a more reliable source.
youtube-dl is a great tool for doing this.


Good point, but the topic talks about YouTube life streams...
Didi Kunz
CasparCG Client-Programmer, Template Maker & Live CG-Operator
Media Support, CH-5722 Gränichen, Switzerland http://mediasupport.ch/
Problems? Guide to posting Bug reports & Feature requests
User avatar
didikunz
 
Posts: 3480
Joined: 10 May 2010, 09:08
Location: Aarau, Switzerland

Re: Fullscreen Playback of YouTube live streams

Postby Swordh » 13 Mar 2016, 23:40

didikunz wrote:Good point, but the topic talks about YouTube life streams...


oh.... then youtube-dl won't do you any good =)
Swordh
 
Posts: 12
Joined: 20 Oct 2014, 15:20

Re: Fullscreen Playback of YouTube live streams

Postby Theo » 22 Nov 2016, 12:19

I like to update with some more options
This works fine to get fullscreen playback, auto start playing, for live and normal youtube video's

get the embedcode
PLAY 1-1 [HTML] https://www.youtube.com/embed/wOS4d8Slk-Y

ad these options after ? for HD playback ..
?autoplay=true&showinfo=0&autohide=1&vq=hd1080&nohtml5=1

so this should work
PLAY 1-1 [HTML] https://www.youtube.com/embed/wOS4d8Slk ... &nohtml5=1

the last option directs to flash playback, this is needed for live video
Casper switches automatic to this mode if you don't use this option, but with this option it starts faster.
If you get an playback error with caspercg with live streams you need to install the flash software from the CasperCG download site
Regards,
Theo Kooijmans
UniversalDV
User avatar
Theo
 
Posts: 92
Joined: 03 Jun 2012, 10:44
Location: The Netherlands

Re: Fullscreen Playback of YouTube live streams

Postby jladnil » 13 Jan 2017, 09:59

I am getting system error whenever i try to play Live Streams " The Program can't start because libgcc_s_sjlj-1.dll is missing from your computer. Try reinstalling the program to fix this problem."

Other videos play fine
jladnil
 
Posts: 8
Joined: 09 Jan 2017, 16:26

Re: Fullscreen Playback of YouTube live streams

Postby jladnil » 17 Jan 2017, 12:23

Now i get this whenever i try to play live streams but surprisingly non live videos play fine
Code: Select all
2017-01-17 16:43:51.139] [9428]  [info]    Received message from 127.0.0.1: stop 1-91\r\n
[2017-01-17 16:43:51.140] [10600] [debug]   Executed command: StopCommand
[2017-01-17 16:43:51.140] [6996]  [warning] html[https://www.youtube.com/embed/gkSeQJThUzw??autoplay=true&showinfo=0&autohide=1&nohtml5=1] window.requestAnimationFrame() never called. Animations might have been laggy
[2017-01-17 16:43:51.140] [10600] [info]    Sent message to 127.0.0.1: 202 STOP OK\r\n
[2017-01-17 16:43:51.140] [6996]  [info]    html[https://www.youtube.com/embed/gkSeQJThUzw??autoplay=true&showinfo=0&autohide=1&nohtml5=1] Uninitialized.
[2017-01-17 16:43:53.696] [9428]  [info]    Received message from 127.0.0.1: play 1-91 [HTML] "https://www.youtube.com/embed/gkSeQJThUzw??autoplay=true&showinfo=0&autohide=1&nohtml5=1"\r\n
[2017-01-17 16:43:53.697] [10600] [info]    html[https://www.youtube.com/embed/gkSeQJThUzw??autoplay=true&showinfo=0&autohide=1&nohtml5=1] Initialized.
[2017-01-17 16:43:53.699] [10600] [info]    transition[empty=>html[https://www.youtube.com/embed/gkSeQJThUzw??autoplay=true&showinfo=0&autohide=1&nohtml5=1]] Initialized.
[2017-01-17 16:43:53.699] [10600] [debug]   Executed command: PlayCommand
[2017-01-17 16:43:53.699] [10600] [info]    Sent message to 127.0.0.1: 202 PLAY OK\r\n
[2017-01-17 16:43:53.735] [10948] [info]    transition[empty=>html[https://www.youtube.com/embed/gkSeQJThUzw??autoplay=true&showinfo=0&autohide=1&nohtml5=1]] End Of File.
[2017-01-17 16:43:53.735] [10948] [info]    transition[empty=>html[https://www.youtube.com/embed/gkSeQJThUzw??autoplay=true&showinfo=0&autohide=1&nohtml5=1]] Uninitialized.
jladnil
 
Posts: 8
Joined: 09 Jan 2017, 16:26


Return to Content

Who is online

Users browsing this forum: No registered users and 2 guests

cron