Re: [Sticky] CasparCG 2.0 - Disk Consumer [Updated 12-02-25]

didikunz wrote:
Robert Nagy wrote:
jespers wrote:Are there console commands which aren't AMCP commands?
So there must be some AMCP commands, that are not in the wiki.
It seems so.

This is all the commands.

Code: Select all

CasparCG Integrator, Developer and Consultant
Former CasparCG Lead Developer
Feel free to contact me ( if you need any CasparCG related support, development or other consulting.

Re: [Sticky] CasparCG 2.0 - Disk Consumer [Updated 12-02-25]

Jonas Hummelstrand wrote:Hmm, I wonder why, Robert! ;)

I'll add the headings in the wiki, and we'll try to figure out what they do together, OK?

PRINT dumps a frame to a png in the data folder
DATA is already defined in the wiki (DATA LIST, DATA STORE, DATA RETRIEVE)
CHANNEL_GRID opens a new channel with a grid of the channels. As far as I know this is the only way to add a channel to another channel.

Re: [Sticky] CasparCG 2.0 - Disk Consumer [Updated 12-02-25]

For high quality ingest (lossless) it's worth to try new codec utvideo (it requires quite new ffmpeg build- eg 1.0). I'm not 100% sure if ffmpeg implementation is well threaded, but original codec is blazing fast- it can easily encode/decode 4K on i7 machine.
Codec can be fund here (it works basically in every NLE once installed- Premiere, Edius-very well, Vegas, Avid...):

There is also MAC version.

FFmpeg uses its own implementation, which is quite new but even on single 2.5Ghz core it should be able to record HD.

Command is:

-vcodec utvideo (no bitrate as it's 100% lossless codec)- typical compression ratio is around 2.5, but can be as low as 1.5 or as high as 3.5 depending on the source nature

note- if incoming signal is RGB it will use RGB mode, if YUV it will encode in YUV 4:2:2 mode. For forced 4:2:2 encoding:

-pix_fmt yuv422p -vcodec utvideo (for Windows it needs to be AVI for MAC rather MOV)

update- looks like ffmpeg utvideo encoding is not threaded yet, but it can do 45fps on one core of 3Ghz i7
Last edited by Andrew_HD on 14 Nov 2012, 11:22, edited 2 times in total.

Re: [Sticky] CasparCG 2.0 - Disk Consumer [Updated 12-02-25]

Thanks Andrew_HD, I'll ping the developers about this! I'm not sure which version of FFmpeg is compiled into Server 2.0.

If you are a compression maven, perhaps you can help aircooled76 and me with a table of recording parameters and options that is sorely missing from our documentation? I'll PM you!
Jonas Hummelstrand
Independent Consultant at
Former Community Manager for CasparCG

Problems? Guide to posting Bug reports & Feature requests

Re: [Sticky] CasparCG 2.0 - Disk Consumer [Updated 12-02-25]

I'm now running the latest stable (2.0.3) version but when recording to h264 I get just pixelated video after a few seconds. Same happened with the beta version (build 3548) and I made a bug report about it. Are some of you recording to h264 and is it working? The earlier stable version worked well the first time with h264 but after that (without restarting casparcg) it recorded just black without any errors (also visible on the diag window).

I'm capturing the input from a Decklink Duo card using this command: ADD 1 FILE -vcodec libx264
If I choose DNxHD it works perfectly but sometimes h264 would be good enough.


Re: [Sticky] CasparCG 2.0 - Disk Consumer [Updated 12-02-25]

Good morning, afternoon, evening.

You can record ProRes in 1080i5000?
I have no problem ProRes PAL.
But ProRes 1080I5000 the recording is played twice faster.

I am using Caspar 2.0.6
Blackmagic DeckLink 4K card or DeckLink Duo Extreme
The computer is an i7 with 12GB of RAM
And SSD hard disk

And this is the command that sent CasparCG

ADD 1 FILE "" -vcodec ProRes -profile 3

Thank you very much and once again congratulations for this great job.

NOTE: sorry for my English.

Re: [Sticky] CasparCG 2.0 - Disk Consumer [Updated 12-02-25]

I'm trying to set the audio bitrate with -ab but then it also changes the video bitrate. I tried caspacCG 2.0.7 beta, 2.0.7, 2.0.6 and 2.0.4.

My command: ADD 1 FILE \"diDghD-MEOU.mp4\"-vcodec libx264 -b 2000k -profile baseline -level 31 -s 1280x720 -f mp4 -pix_fmt yuv420p -acodec libvo_aacenc -ab 192k -ac 2 -ar 48000 -movflags faststart

Code: Select all

[2015-06-30 15:29:01.601] [056929C8] [info]    Received message from PLAY 1-20 "go1080p25" MIX 50 Linear RIGHT LOOP\r\n
[2015-06-30 15:29:01.634] [0582D270] [info]    ffmpeg[go1080p25.mp4|1920x1088i50.00|0/439] [video-decoder] H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
[2015-06-30 15:29:01.638] [0582D270] [warning] [audio-resampler] sample-rate: 48000 channels: 2 sample-fmt: s16      16 
[2015-06-30 15:29:01.638] [0582D270] [debug]   [audio-decoder] MP3 (MPEG audio layer 3) Selected channel layout STEREO
[2015-06-30 15:29:01.639] [0582D270] [info]    ffmpeg[go1080p25.mp4|1920x1088i50.00|0/439] [audio-decoder] MP3 (MPEG audio layer 3)
[2015-06-30 15:29:01.639] [0582D270] [info]    transition[empty=>ffmpeg[go1080p25.mp4|1920x1088i50.00|0/439]] Initialized.
[2015-06-30 15:29:01.639] [0582D270] [debug]   Executed command: PlayCommand
[2015-06-30 15:29:01.639] [0582D270] [info]    Sent message to 202 PLAY OK\r\n
[2015-06-30 15:29:01.659] [056BD428] [error]   [ffmpeg] [NULL @ 02DF1840] [Eval @ 0643F3D4] Undefined constant or missing '(' in 'baseline'
[2015-06-30 15:29:01.659] [056BD428] [error]   [ffmpeg] [NULL @ 02DF1840] Unable to parse option value "baseline"
[2015-06-30 15:29:01.660] [056BD428] [warning] [ffmpeg] [libx264 @ 02DF1840] frame MB size (80x46) > level limit (3600)
[2015-06-30 15:29:01.660] [056BD428] [info]    [ffmpeg] [libx264 @ 02DF1840] using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.2 AVX
[2015-06-30 15:29:01.664] [056BD428] [info]    [ffmpeg] [libx264 @ 02DF1840] profile Main, level 3.1
[2015-06-30 15:29:01.665] [056BD428] [info]    [ffmpeg] [libx264 @ 02DF1840] 264 - core 118 r2085 8a62835 - H.264/MPEG-4 AVC codec - Copyleft 2003-2011 - - options: cabac=0 ref=3 deblock=1:0:0 analyse=0x1:0x111 me=hex subme=7 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=0 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=4 sliced_threads=0 nr=0 decimate=1 interlaced=tff bluray_compat=0 constrained_intra=0 bframes=0 weightp=0 keyint=25 keyint_min=2 scenecut=40 intra_refresh=0 rc_lookahead=25 rc=abr mbtree=1 bitrate=192 ratetol=1.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
[2015-06-30 15:29:01.665] [056BD428] [error]   [ffmpeg] [NULL @ 0BB28B00] [Eval @ 0643F3F4] Undefined constant or missing '(' in 'baseline'
[2015-06-30 15:29:01.665] [056BD428] [error]   [ffmpeg] [NULL @ 0BB28B00] Unable to parse option value "baseline"
[2015-06-30 15:29:01.665] [056BD428] [info]    [ffmpeg] Output #0, mp4, to 'media\DIDGHD-MEOU.MP4':
[2015-06-30 15:29:01.665] [056BD428] [info]    [ffmpeg]     Stream #0:
[2015-06-30 15:29:01.665] [056BD428] [info]    [ffmpeg] : Video: h264, yuv420p, 1280x720, q=-1--1, 192 kb/
[2015-06-30 15:29:01.665] [056BD428] [info]    [ffmpeg] , 90k tb
[2015-06-30 15:29:01.665] [056BD428] [info]    [ffmpeg] , 25 tb
[2015-06-30 15:29:01.665] [056BD428] [info]    [ffmpeg] 
[2015-06-30 15:29:01.665] [056BD428] [info]    [ffmpeg]     Stream #0:
[2015-06-30 15:29:01.665] [056BD428] [info]    [ffmpeg] : Audio: aac, 48000 Hz, 2 channels, s16, 192 kb/
[2015-06-30 15:29:01.666] [056BD428] [info]    [ffmpeg] 
[2015-06-30 15:29:01.666] [056BD428] [warning] Invalid option: -profile baseline
[2015-06-30 15:29:01.666] [056BD428] [warning] Invalid option: -movflags faststart
result of encoding video in 192kb is pretty cool:

And is there some way to set the MOOV position? Because the record output must have it in the beginning: ... _002c-ismv
System specs:
Intel i5 3.4GHz
8GB ram
BM Decklink HD Extreme
Win7 SP1 64bit