Simple PAL output with DeckLink ?

#1
Hello all,
I simply want an PAL output with a decklink consumer only.
All the tests I do are not OK. At the blackmagic board I get a "no signal" message on my display.
I'm working on Windows 10 with DUO or QUAD boards.
Attached my config file and the log.
Each time I get the message [warning] Device does not support video-format: PAL.
If I try to set an HD channel (1080i5000) and if I set a down conversion in the BMD driver, I get the same result : no video output of a black screen.
Is it possible to have this simple system ?
I use BMD driver 10.9.3 (same result with 10.8.4).

Code: Select all

 <channels>
    <channel>
      <video-mode>PAL</video-mode>
      <channel-layout>stereo</channel-layout>
      <consumers>
        <decklink>
          <device>1</device>
          <embedded-audio>true</embedded-audio>
          <channel-layout>stereo</channel-layout>
          <latency>low</latency>
          <keyer>internal</keyer>
          <key-only>false</key-only>
          <buffer-depth>3</buffer-depth>
          <op47-vanc-line>none</op47-vanc-line>
        </decklink>
      </consumers>
    </channel>
  </channels>
the results

Code: Select all

[2017-06-06 17:09:56.476] [12804] [info]    Initialized audio config.
[2017-06-06 17:09:56.477] [12804] [info]    Initializing OpenGL Device.
[2017-06-06 17:09:57.322] [12804] [info]    Successfully initialized OpenGL 4.5.0 NVIDIA 361.91 NVIDIA Corporation
[2017-06-06 17:09:57.327] [12804] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 1
[2017-06-06 17:09:57.328] [12804] [info]    video_channel[1|PAL] Successfully Initialized.
[2017-06-06 17:09:57.509] [4932]  [debug]   [audio_channel_remapper] Input:  [audio_channel_layout] num_channels=2 type=STEREO channel_order=FL FR
[2017-06-06 17:09:57.509] [4932]  [debug]   [audio_channel_remapper] Output: [audio_channel_layout] num_channels=2 type=STEREO channel_order=FL FR
[2017-06-06 17:09:57.509] [4932]  [debug]   [audio_channel_remapper] No remapping/mixing needed because the input and output layout is equal.
[2017-06-06 17:09:57.509] [4932]  [warning] Device does not support video-format: PAL
[2017-06-06 17:09:57.509] [4932]  [info]    DeckLink SDI [1-1|PAL] Enabled embedded-audio.
[2017-06-06 17:09:57.510] [4932]  [info]    DeckLink SDI [1-1|PAL] Enabled subtitle on line -1
[2017-06-06 17:09:57.510] [4932]  [info]    DeckLink SDI [1-1|PAL] Enabled low-latency mode.
[2017-06-06 17:09:57.510] [4932]  [info]    DeckLink SDI [1-1|PAL] Enabled internal keyer.
[2017-06-06 17:09:57.521] [12804] [info]    DeckLink SDI [1-1|PAL] Initialized.
[2017-06-06 17:09:57.521] [12804] [info]    Initialized channels.
[2017-06-06 17:09:57.521] [12804] [info]    Initialized thumbnail generator.
[2017-06-06 17:09:57.522] [12804] [info]    Initialized controllers.

Re: Simple PAL output with DeckLink ?

#2
Where is that

Code: Select all

 <op47-vanc-line>none</op47-vanc-line>
line coming from? I never saw this. Try, what happens, if you delete it.

What Decklink Duo cards do you use? The old or the new Duo 2 / Quad 2? Can you play video with the "Media Express" software coming with the cards?

Could you post a little bit more of the log-file?
Didi Kunz
CasparCG Client-Programmer, Template Maker & Live CG-Operator
Media Support, CH-5722 Gränichen, Switzerland http://mediasupport.ch/
Problems? Guide to posting Bug reports & Feature requests

Re: Simple PAL output with DeckLink ?

#3
Here are some details: we are using DUO and QUAD (no DUO2/QUAD2).
The line op47 is a internal test, if deleted the behaviour is the same.
Yes I can play with MediaExpress after a capture, not tested in PAL.
About PAL and CasparCG : when casparCG is started, I can read PAL in the BMD stup tool for the channel, but no video on the output.
Here is the complete log.

Code: Select all

[2017-06-07 09:53:56.475] [16340] [warning] Element thumbnails-path in casparcg.config has been deprecated. Use thumbnail-path instead.
[2017-06-07 09:53:56.476] [16340] [info]    ############################################################################
[2017-06-07 09:53:56.476] [16340] [info]    CasparCG Server is distributed by the Swedish Broadcasting Corporation (SVT)
[2017-06-07 09:53:56.476] [16340] [info]    under the GNU General Public License GPLv3 or higher.
[2017-06-07 09:53:56.476] [16340] [info]    Please see LICENSE.TXT for details.
[2017-06-07 09:53:56.476] [16340] [info]    http://www.casparcg.com/
[2017-06-07 09:53:56.476] [16340] [info]    ############################################################################
[2017-06-07 09:53:56.478] [16340] [info]    Starting CasparCG Video and Graphics Playout Server 2.1.0.0 by SGT
[2017-06-07 09:53:56.478] [16340] [info]    on Windows 10 Pro 
[2017-06-07 09:53:56.478] [16340] [info]    Intel(R) Xeon(R) CPU E5-2620 v3 @ 2.40GHz Physical Threads: 12
[2017-06-07 09:53:56.478] [16340] [info]    Precision Rack 7910
[2017-06-07 09:53:56.478] [16340] [info]    Initialized reroute module.
[2017-06-07 09:53:56.479] [16340] [info]    Initialized ffmpeg module.
[2017-06-07 09:53:56.479] [16340] [info]    Initialized oal module.
[2017-06-07 09:53:56.479] [16340] [info]    Initialized decklink module.
[2017-06-07 09:53:56.479] [16340] [info]    Initialized screen module.
[2017-06-07 09:53:56.496] [16340] [info]    Initialized html module.
[2017-06-07 09:53:56.496] [16340] [info]    Initialized newtek module.
[2017-06-07 09:53:56.496] [16340] [info]    Initialized image module.
[2017-06-07 09:53:56.730] [16340] [info]    Loaded C:\Windows\SYSTEM32\Processing.AirSend.x64.dll
[2017-06-07 09:53:56.730] [16340] [info]    ffmpeg.avcodec 56.41.100
[2017-06-07 09:53:56.730] [16340] [info]    ffmpeg.avformat 56.36.100
[2017-06-07 09:53:56.730] [16340] [info]    ffmpeg.avfilter 5.16.101
[2017-06-07 09:53:56.730] [16340] [info]    ffmpeg.avutil 54.27.100
[2017-06-07 09:53:56.730] [16340] [info]    ffmpeg.swscale 3.1.101
[2017-06-07 09:53:56.730] [16340] [info]    decklink.version 10.9.3
[2017-06-07 09:53:56.730] [16340] [info]    decklink.device DeckLink SDI [1]
[2017-06-07 09:53:56.730] [16340] [info]    decklink.device DeckLink SDI [2]
[2017-06-07 09:53:56.730] [16340] [info]    decklink.device DeckLink SDI [3]
[2017-06-07 09:53:56.730] [16340] [info]    decklink.device DeckLink SDI [4]
[2017-06-07 09:53:56.730] [16340] [info]    cef.version 3.1750.1805
[2017-06-07 09:53:56.730] [16340] [info]    cef.chromeversion 33.0.1750.170
[2017-06-07 09:53:56.730] [16340] [info]    newtek-ivga.version available
[2017-06-07 09:53:56.731] [16340] [info]    freeimage 3.16.0
[2017-06-07 09:53:56.731] [16340] [info]    casparcg.config:
[2017-06-07 09:53:56.731] [16340] [info]    -----------------------------------------
[2017-06-07 09:53:56.731] [16340] [info]    <?xml version="1.0" encoding="utf-8"?>
[2017-06-07 09:53:56.731] [16340] [info]    <configuration>
[2017-06-07 09:53:56.731] [16340] [info]       <paths>
[2017-06-07 09:53:56.731] [16340] [info]          <media-path>O:\media\</media-path>
[2017-06-07 09:53:56.731] [16340] [info]          <log-path>O:\logs\</log-path>
[2017-06-07 09:53:56.731] [16340] [info]          <data-path>O:\Data\</data-path>
[2017-06-07 09:53:56.731] [16340] [info]          <template-path>O:\templates\</template-path>
[2017-06-07 09:53:56.731] [16340] [info]          <thumbnails-path>O:\thumbnails\</thumbnails-path>
[2017-06-07 09:53:56.731] [16340] [info]       </paths>
[2017-06-07 09:53:56.731] [16340] [info]       <log-level>info</log-level>
[2017-06-07 09:53:56.731] [16340] [info]       <channel-grid>false</channel-grid>
[2017-06-07 09:53:56.731] [16340] [info]       <blend-modes>false</blend-modes>
[2017-06-07 09:53:56.731] [16340] [info]       <auto-transcode>false</auto-transcode>
[2017-06-07 09:53:56.731] [16340] [info]       <flash>
[2017-06-07 09:53:56.731] [16340] [info]          <buffer-depth>auto</buffer-depth>
[2017-06-07 09:53:56.731] [16340] [info]       </flash>
[2017-06-07 09:53:56.731] [16340] [info]       <thumbnails>
[2017-06-07 09:53:56.731] [16340] [info]          <generate-thumbnails>false</generate-thumbnails>
[2017-06-07 09:53:56.731] [16340] [info]          <width>256</width>
[2017-06-07 09:53:56.731] [16340] [info]          <height>144</height>
[2017-06-07 09:53:56.731] [16340] [info]          <video-grid>1</video-grid>
[2017-06-07 09:53:56.731] [16340] [info]          <scan-interval-millis>5000</scan-interval-millis>
[2017-06-07 09:53:56.731] [16340] [info]          <generate-delay-millis>1000</generate-delay-millis>
[2017-06-07 09:53:56.731] [16340] [info]          <video-mode>720p2500</video-mode>
[2017-06-07 09:53:56.731] [16340] [info]       </thumbnails>
[2017-06-07 09:53:56.731] [16340] [info]       <channels>
[2017-06-07 09:53:56.731] [16340] [info]          <channel>
[2017-06-07 09:53:56.731] [16340] [info]             <video-mode>PAL</video-mode>
[2017-06-07 09:53:56.731] [16340] [info]             <channel-layout>stereo</channel-layout>
[2017-06-07 09:53:56.731] [16340] [info]             <consumers>
[2017-06-07 09:53:56.731] [16340] [info]                <decklink>
[2017-06-07 09:53:56.731] [16340] [info]                   <device>1</device>
[2017-06-07 09:53:56.731] [16340] [info]                   <embedded-audio>true</embedded-audio>
[2017-06-07 09:53:56.731] [16340] [info]                   <channel-layout>stereo</channel-layout>
[2017-06-07 09:53:56.731] [16340] [info]                   <latency>low</latency>
[2017-06-07 09:53:56.731] [16340] [info]                   <keyer>internal</keyer>
[2017-06-07 09:53:56.731] [16340] [info]                   <key-only>false</key-only>
[2017-06-07 09:53:56.731] [16340] [info]                   <buffer-depth>3</buffer-depth>
[2017-06-07 09:53:56.731] [16340] [info]                </decklink>
[2017-06-07 09:53:56.731] [16340] [info]             </consumers>
[2017-06-07 09:53:56.731] [16340] [info]          </channel>
[2017-06-07 09:53:56.731] [16340] [info]       </channels>
[2017-06-07 09:53:56.731] [16340] [info]       <audio>
[2017-06-07 09:53:56.731] [16340] [info]          <channel-layouts/>
[2017-06-07 09:53:56.731] [16340] [info]          <streams-inuse/>
[2017-06-07 09:53:56.731] [16340] [info]          <maxstreams>2</maxstreams>
[2017-06-07 09:53:56.731] [16340] [info]          <maxchannels>2</maxchannels>
[2017-06-07 09:53:56.731] [16340] [info]       </audio>
[2017-06-07 09:53:56.731] [16340] [info]       <osc>
[2017-06-07 09:53:56.731] [16340] [info]          <default-port>6250</default-port>
[2017-06-07 09:53:56.731] [16340] [info]          <predefined-clients/>
[2017-06-07 09:53:56.731] [16340] [info]       </osc>
[2017-06-07 09:53:56.731] [16340] [info]       <controllers>
[2017-06-07 09:53:56.731] [16340] [info]          <tcp>
[2017-06-07 09:53:56.731] [16340] [info]             <protocol>AMCP</protocol>
[2017-06-07 09:53:56.731] [16340] [info]             <port>5250</port>
[2017-06-07 09:53:56.731] [16340] [info]          </tcp>
[2017-06-07 09:53:56.731] [16340] [info]       </controllers>
[2017-06-07 09:53:56.731] [16340] [info]    </configuration>
[2017-06-07 09:53:56.731] [16340] [info]    -----------------------------------------
[2017-06-07 09:53:56.731] [16340] [info]    Initialized audio config.
[2017-06-07 09:53:56.732] [16340] [info]    Initializing OpenGL Device.
[2017-06-07 09:53:57.642] [16340] [info]    Successfully initialized OpenGL 4.5.0 NVIDIA 361.91 NVIDIA Corporation
[2017-06-07 09:53:57.648] [16340] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 1
[2017-06-07 09:53:57.648] [16340] [info]    video_channel[1|PAL] Successfully Initialized.
[2017-06-07 09:53:57.828] [4900]  [warning] Device does not support video-format: PAL
[2017-06-07 09:53:57.829] [4900]  [info]    DeckLink SDI [1-1|PAL] Enabled embedded-audio.
[2017-06-07 09:53:57.829] [4900]  [info]    DeckLink SDI [1-1|PAL] Enabled subtitle on line -1
[2017-06-07 09:53:57.829] [4900]  [info]    DeckLink SDI [1-1|PAL] Enabled low-latency mode.
[2017-06-07 09:53:57.829] [4900]  [info]    DeckLink SDI [1-1|PAL] Enabled internal keyer.
[2017-06-07 09:53:57.839] [16340] [info]    DeckLink SDI [1-1|PAL] Initialized.
[2017-06-07 09:53:57.839] [16340] [info]    Initialized channels.
[2017-06-07 09:53:57.840] [16340] [info]    Initialized thumbnail generator.
[2017-06-07 09:53:57.840] [16340] [info]    Initialized controllers.
[2017-06-07 09:53:57.840] [16340] [info]    Started initial media information retrieval.
[2017-06-07 09:53:57.978] [17164] [info]    DeckLink SDI [1-1|PAL] Reference signal: not detected.
[2017-06-07 09:54:00.529] [17160] [info]    Initial media information retrieval finished.

Re: Simple PAL output with DeckLink ?

#4
Grab2.PNG
Grab2.PNG (13.3 KiB) Viewed 1863 times
It seems, that you use a version of CasparCG, that is modified by SGT. So plese ask their support for help. https://www.sgt.eu/index.php/en/ or download the official version from the download page.
Didi Kunz
CasparCG Client-Programmer, Template Maker & Live CG-Operator
Media Support, CH-5722 Gränichen, Switzerland http://mediasupport.ch/
Problems? Guide to posting Bug reports & Feature requests

Re: Simple PAL output with DeckLink ?

#6
Canigou77 wrote:I'm from SGT.

That's bad, would be elegant to let their support handle the problem :)
Canigou77 wrote:Yes I can play with MediaExpress after a capture, not tested in PAL.
Can you do this test, please?

It's weird, because it should work. There are sometimes problems with Dell BIOSes not being compatible with Decklink. But if it works with Media Express it should also with Caspar.
Didi Kunz
CasparCG Client-Programmer, Template Maker & Live CG-Operator
Media Support, CH-5722 Gränichen, Switzerland http://mediasupport.ch/
Problems? Guide to posting Bug reports & Feature requests

Re: Simple PAL output with DeckLink ?

#7
Test with MediaExpress : with a Decklink DUO, on a shuttle machine (not a DELL) : capture and playback in PAL is working well.

As soon as I launch casparCG with a channel in PAL : no video at the output.

-------------------

Does somebody know why decklink consumer say "PAL not supported" ?

Re: Simple PAL output with DeckLink ?

#8
I'm not able to help with your problem I'm afraid, only to say that I run several units with Duo2 and Quad2 cards, all in PAL and they all work. One box is currently outputting 16 PAL channels without issue.

What version of the Decklink driver are you running? I've had issues with anything newer than 10.8.5

Re: Simple PAL output with DeckLink ?

#10
Canigou77 wrote: @ASmith3006 : can you me a piece of your config file ?
Wich version of CasparCG do you use ?
Sure, below.

I'm running 2.0.7 server on Windows 7

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <paths>
<!--    <media-path>media\</media-path>//-->
    <media-path>y:\</media-path>
    <log-path>log\</log-path>
    <data-path>data\</data-path>
    <template-path>templates\</template-path>
    <thumbnails-path>thumbnails\</thumbnails-path>
  </paths>
<thumbnails>
    <generate-thumbnails>true</generate-thumbnails>
    <width>256</width>
    <height>144</height>
    <video-grid>2</video-grid>
    <scan-interval-millis>5000</scan-interval-millis>
    <generate-delay-millis>2000</generate-delay-millis>
    <video-mode>720p2500</video-mode>
    <mipmap>true</mipmap>
</thumbnails>
  <channels>
     <channel>
        <video-mode>PAL</video-mode>
        <channel-layout>stereo</channel-layout>
        <consumers>
            <decklink>
                <device>1</device>
                <embedded-audio>true</embedded-audio>
            </decklink>
        </consumers>
    </channel>
     <channel>
        <video-mode>PAL</video-mode>
        <channel-layout>stereo</channel-layout>
        <consumers>
            <decklink>
                <device>2</device>
                <embedded-audio>true</embedded-audio>
            </decklink>
        </consumers>
    </channel>
     <channel>
        <video-mode>PAL</video-mode>
        <channel-layout>stereo</channel-layout>
        <consumers>
            <decklink>
                <device>3</device>
                <embedded-audio>true</embedded-audio>
            </decklink>
        </consumers>
    </channel>
     <channel>
        <video-mode>PAL</video-mode>
        <channel-layout>stereo</channel-layout>
        <consumers>
            <decklink>
                <device>4</device>
                <embedded-audio>true</embedded-audio>
            </decklink>
        </consumers>
    </channel>
     <channel>
        <video-mode>PAL</video-mode>
        <channel-layout>stereo</channel-layout>
        <consumers>
            <decklink>
                <device>5</device>
                <embedded-audio>true</embedded-audio>
            </decklink>
        </consumers>
    </channel>
     <channel>
        <video-mode>PAL</video-mode>
        <channel-layout>stereo</channel-layout>
        <consumers>
            <decklink>
                <device>6</device>
                <embedded-audio>true</embedded-audio>
            </decklink>
        </consumers>
    </channel>
     <channel>
        <video-mode>PAL</video-mode>
        <channel-layout>stereo</channel-layout>
        <consumers>
            <decklink>
                <device>7</device>
                <embedded-audio>true</embedded-audio>
            </decklink>
        </consumers>
    </channel>
     <channel>
        <video-mode>PAL</video-mode>
        <channel-layout>stereo</channel-layout>
        <consumers>
            <decklink>
                <device>8</device>
                <embedded-audio>true</embedded-audio>
            </decklink>
        </consumers>
    </channel>
     <channel>
        <video-mode>PAL</video-mode>
        <channel-layout>stereo</channel-layout>
        <consumers>
            <decklink>
                <device>9</device>
                <embedded-audio>true</embedded-audio>
            </decklink>
        </consumers>
    </channel>
     <channel>
        <video-mode>PAL</video-mode>
        <channel-layout>stereo</channel-layout>
        <consumers>
            <decklink>
                <device>10</device>
                <embedded-audio>true</embedded-audio>
            </decklink>
        </consumers>
    </channel>
     <channel>
        <video-mode>PAL</video-mode>
        <channel-layout>stereo</channel-layout>
        <consumers>
            <decklink>
                <device>11</device>
                <embedded-audio>true</embedded-audio>
            </decklink>
        </consumers>
    </channel>
     <channel>
        <video-mode>PAL</video-mode>
        <channel-layout>stereo</channel-layout>
        <consumers>
            <decklink>
                <device>12</device>
                <embedded-audio>true</embedded-audio>
            </decklink>
        </consumers>
    </channel>
  </channels>
  <controllers>
    <tcp>
        <port>5250</port>
        <protocol>AMCP</protocol>
    </tcp>
  </controllers>
</configuration>