It is currently 22 Jun 2017, 19:34



VMWARE Fusion on mac screen consumers black screen

CasparCG Server, Client and development

Moderators: Macey, Jonas Hummelstrand, didikunz

VMWARE Fusion on mac screen consumers black screen

Postby thomasdesliens » 17 May 2017, 13:03

Hello everyone,

I installed casparcg server on my Imac windows desktop on the external disk using Vmware and the client on my Imac. I can see medias on the client and when i play a media i can hear the sound of the media but i have no image on the consumer screen..
I don't know anything about log language so i really need your help.

And if i want to connect (via thunderbold-HDMI) my Imac to an external device like Atem, how i can root easily the output of the server ?



thank you very much !
[2017-05-17 14:01:31.127] [3204] [info] ############################################################################
[2017-05-17 14:01:31.128] [3204] [info] CasparCG Server is distributed by the Swedish Broadcasting Corporation (SVT)
[2017-05-17 14:01:31.128] [3204] [info] under the GNU General Public License GPLv3 or higher.
[2017-05-17 14:01:31.128] [3204] [info] Please see LICENSE.TXT for details.
[2017-05-17 14:01:31.128] [3204] [info] http://www.casparcg.com/
[2017-05-17 14:01:31.128] [3204] [info] ############################################################################
[2017-05-17 14:01:31.128] [3204] [info] Starting CasparCG Video and Graphics Playout Server 2.0.7.e9fc25a Stable
[2017-05-17 14:01:31.128] [3204] [info] on Windows 7 Ultimate Service Pack 1
[2017-05-17 14:01:31.128] [3204] [info] Intel(R) Core(TM) i5-4570R CPU @ 2.70GHz Physical Threads: 1
[2017-05-17 14:01:31.128] [3204] [info] VMware Virtual Platform
[2017-05-17 14:01:31.167] [3204] [info] Decklink Not found
[2017-05-17 14:01:31.169] [3204] [info] Bluefish Not found
[2017-05-17 14:01:31.169] [3204] [info] FreeImage 3.15.4
[2017-05-17 14:01:31.169] [3204] [info] FFMPEG-avcodec 55.52.102
[2017-05-17 14:01:31.169] [3204] [info] FFMPEG-avformat 55.33.100
[2017-05-17 14:01:31.170] [3204] [info] FFMPEG-avfilter 4.2.100
[2017-05-17 14:01:31.170] [3204] [info] FFMPEG-avutil 52.66.100
[2017-05-17 14:01:31.170] [3204] [info] FFMPEG-swscale 2.5.102
[2017-05-17 14:01:31.170] [3204] [info] Flash Not found
[2017-05-17 14:01:31.175] [3204] [info] flash[cg20.fth.pal|0] Initialized.
[2017-05-17 14:01:31.175] [3204] [info] flash[cg20.fth.pal|0] Invoking info-command: <invoke name="GetInfo" returntype="xml"><arguments></arguments></invoke>
[2017-05-17 14:01:31.177] [3552] [error] producer\flash_producer.cpp(217): Throw in function __thiscall caspar::flash::flash_renderer::flash_renderer(const class caspar::safe_ptr<class caspar::diagnostics::graph> &,const class std::tr1::shared_ptr<struct caspar::core::frame_factory> &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,int,int)
Dynamic exception type: class boost::exception_detail::clone_impl<struct caspar::caspar_exception>
std::exception::what: Unknown exception
[struct caspar::tag_msg_info *] = flash-player[cg20.fth.pal|1024x576] Failed to Create FlashAxControl

[2017-05-17 14:01:31.179] [3204] [trace] Template-Host Unknown
[2017-05-17 14:01:31.180] [3204] [info] NewTek iVGA unavailable (Processing.AirSend.x86.dll)
[2017-05-17 14:01:31.180] [3204] [info] casparcg.config:
-----------------------------------------
<?xml version="1.0" encoding="utf-8"?>
<configuration>
<paths>
<media-path>media\</media-path>
<log-path>log\</log-path>
<data-path>data\</data-path>
<template-path>templates\</template-path>
<thumbnails-path>thumbnails\</thumbnails-path>
</paths>
<channels>
<channel>
<video-mode>PAL</video-mode>
<consumers>
<screen>
<device>1</device>
</screen>
<system-audio/>
</consumers>
</channel>
</channels>
<controllers>
<tcp>
<port>5250</port>
<protocol>AMCP</protocol>
</tcp>
</controllers>
</configuration>
-----------------------------------------
[2017-05-17 14:01:31.180] [3204] [info] Initialized html module.
[2017-05-17 14:01:31.185] [3204] [info] Initializing OpenGL Device.
[2017-05-17 14:01:31.195] [1828] [info] OpenGL 3.0 Mesa 10.6.0 (git-beb7765) VMware, Inc.
[2017-05-17 14:01:31.195] [1828] [info] Successfully initialized OpenGL Device.
[2017-05-17 14:01:31.196] [404] [info] flash[cg20.fth.pal|0] Uninitialized.
[2017-05-17 14:01:31.200] [3204] [info] Initialized ffmpeg module.
[2017-05-17 14:01:31.200] [3204] [info] Initialized bluefish module.
[2017-05-17 14:01:31.202] [3204] [info] Initialized decklink module.
[2017-05-17 14:01:31.202] [3204] [info] Initialized oal module.
[2017-05-17 14:01:31.202] [3204] [info] Initialized newtek module.
[2017-05-17 14:01:31.202] [3204] [info] Initialized ogl module.
[2017-05-17 14:01:31.202] [3204] [info] Initialized flash module.
[2017-05-17 14:01:31.202] [3204] [info] Initialized image module.
[2017-05-17 14:01:31.238] [1828] [info] [shader] Blend-modes are disabled.
[2017-05-17 14:01:31.239] [3204] [warning] [image_mixer] TextureBarrierNV not supported. Post processing will not be available
[2017-05-17 14:01:31.241] [3204] [info] video_channel[1|PAL] Successfully Initialized.
[2017-05-17 14:01:31.243] [3204] [info]
+---------------+
| filter_buffer |default--[720x576 64:45 bgra]--auto-inserted scaler 1:default
| (buffer) |
+---------------+

+-------------------+
auto-inserted scaler 0:default--[720x576 64:45 bgra]--default| filter_buffersink |
| (buffersink) |
+-------------------+

+-----------------+
auto-inserted scaler 1:default--[720x576 64:45 gbrp]--default| Parsed_format_0 |default--[720x576 64:45 gbrp]--Parsed_yadif_1:default
| (format) |
+-----------------+

+----------------+
Parsed_format_0:default--[720x576 64:45 gbrp]--default| Parsed_yadif_1 |default--[720x576 64:45 gbrp]--auto-inserted scaler 0:default
| (yadif) |
+----------------+

+------------------------+
Parsed_yadif_1:default--[720x576 64:45 gbrp]--default| auto-inserted scaler 0 |default--[720x576 64:45 bgra]--filter_buffersink:default
| (scale) |
+------------------------+

+------------------------+
filter_buffer:default--[720x576 64:45 bgra]--default| auto-inserted scaler 1 |default--[720x576 64:45 gbrp]--Parsed_format_0:default
| (scale) |
+------------------------+


[2017-05-17 14:01:31.249] [3204] [info] Screen consumer [1|PAL] Successfully Initialized.
[2017-05-17 14:01:31.250] [1812] [info] output[1] Screen consumer [1|PAL] Added.
[2017-05-17 14:01:31.340] [2424] [info] Screen consumer [1|PAL] Successfully Initialized.
[2017-05-17 14:01:31.959] [3204] [info] oal[1|PAL] Sucessfully Initialized.
[2017-05-17 14:01:31.960] [1812] [info] output[1] oal[1|PAL] Added.
[2017-05-17 14:01:31.961] [3204] [info] Initialized channels.
[2017-05-17 14:01:31.962] [3204] [warning] [image_mixer] TextureBarrierNV not supported. Post processing will not be available
[2017-05-17 14:01:32.003] [3204] [info] Initialized thumbnail generator.
[2017-05-17 14:01:32.003] [3204] [info] WinSock2 Initialized.
[2017-05-17 14:01:32.004] [3204] [info] Listener successfully initialized
[2017-05-17 14:01:32.004] [3204] [info] Initialized controllers.
[2017-05-17 14:01:32.004] [3204] [info] Initialized osc.
[2017-05-17 14:01:32.004] [3204] [info] Started initial media information retrieval.
[2017-05-17 14:01:32.771] [4084] [info] Initial media information retrieval finished.
[2017-05-17 14:01:34.051] [3804] [info] Accepted connection from 172.16.42.1 2
[2017-05-17 14:01:44.399] [3804] [info] Accepted connection from 172.16.42.1 3
[2017-05-17 14:01:44.428] [3804] [info] Received message from 172.16.42.1: VERSION SERVER\r\n
[2017-05-17 14:01:44.428] [3412] [debug] Executed command: VersionCommand
[2017-05-17 14:01:44.428] [3412] [info] Sent message to 172.16.42.1: 201 VERSION OK\r\n2.0.7.e9fc25a Stable\r\n
[2017-05-17 14:01:44.442] [3804] [info] Received message from 172.16.42.1: INFO\r\n
[2017-05-17 14:01:44.442] [3412] [debug] Executed command: InfoCommand
[2017-05-17 14:01:44.442] [3412] [info] Sent message to 172.16.42.1: 200 INFO OK\r\n1 PAL PLAYING\r\n\r\n
[2017-05-17 14:01:44.457] [3804] [info] Received message from 172.16.42.1: CLS\r\n
[2017-05-17 14:01:44.466] [3412] [debug] Executed command: ClsCommand
[2017-05-17 14:01:44.467] [3412] [info] Sent more than 512 bytes to 172.16.42.1
[2017-05-17 14:01:44.468] [3804] [info] Received message from 172.16.42.1: TLS\r\n
[2017-05-17 14:01:44.468] [3804] [info] Received message from 172.16.42.1: DATA LIST\r\n
[2017-05-17 14:01:44.468] [3804] [info] Received message from 172.16.42.1: THUMBNAIL LIST\r\n
[2017-05-17 14:01:44.473] [3412] [debug] Executed command: TlsCommand
[2017-05-17 14:01:44.473] [3412] [info] Sent more than 512 bytes to 172.16.42.1
[2017-05-17 14:01:44.473] [3412] [debug] Executed command: DataCommand
[2017-05-17 14:01:44.473] [3412] [info] Sent message to 172.16.42.1: 200 DATA LIST OK\r\n\r\n
[2017-05-17 14:01:44.481] [3412] [debug] Executed command: ThumbnailCommand
[2017-05-17 14:01:44.481] [3412] [info] Sent more than 512 bytes to 172.16.42.1
[2017-05-17 14:01:50.290] [3804] [info] Received message from 172.16.42.1: PLAY 1-10 "GO1080P25" CUT 1 Linear RIGHT\r\n
[2017-05-17 14:01:50.306] [312] [info] ffmpeg[go1080p25.mp4|1920x1080i50.00|0/439] [video-decoder] H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
[2017-05-17 14:01:50.310] [312] [debug] [audio-decoder] MP3 (MPEG audio layer 3) Selected channel layout STEREO
[2017-05-17 14:01:50.310] [312] [info] ffmpeg[go1080p25.mp4|1920x1080i50.00|0/439] [audio-decoder] MP3 (MPEG audio layer 3)
[2017-05-17 14:01:50.311] [312] [info] transition[empty=>ffmpeg[go1080p25.mp4|1920x1080i50.00|0/439]] Initialized.
[2017-05-17 14:01:50.311] [312] [debug] Executed command: PlayCommand
[2017-05-17 14:01:50.311] [312] [info] Sent message to 172.16.42.1: 202 PLAY OK\r\n
[2017-05-17 14:01:50.321] [3744] [info] transition[empty=>ffmpeg[go1080p25.mp4|1920x1080i50.00|0/439]] End Of File.
[2017-05-17 14:01:50.321] [3744] [info] transition[empty=>ffmpeg[go1080p25.mp4|1920x1080i50.00|0/439]] Uninitialized.
[2017-05-17 14:01:50.427] [3744] [info]
+---------------+
| filter_buffer |default--[1920x1080 1:1 yuv420p]--filter_buffersink:default
| (buffer) |
+---------------+

+-------------------+
filter_buffer:default--[1920x1080 1:1 yuv420p]--default| filter_buffersink |
| (buffersink) |
+-------------------+


[2017-05-17 14:01:50.429] [3744] [info] [frame_muxer] simple 1920x1080p25.00
thomasdesliens
 
Posts: 2
Joined: 05 May 2017, 00:46

Re: VMWARE Fusion on mac screen consumers black screen

Postby didikunz » 17 May 2017, 16:17

From the log you posted I can see, that Flash is not correctly installed. But that does not explain the problem with the black screen consumer. The only thing I can imagine is, that there is a compatibility issue between Caspar and VMWARE.
Didi Kunz
CasparCG Client-Programmer, Template Maker & Live CG-Operator
Media Support, CH-5722 Gränichen, Switzerland http://mediasupport.ch/
Problems? Guide to posting Bug reports & Feature requests
User avatar
didikunz
 
Posts: 3477
Joined: 10 May 2010, 09:08
Location: Aarau, Switzerland

Re: VMWARE Fusion on mac screen consumers black screen

Postby thomasdesliens » 18 May 2017, 10:04

Thank you for your reply do you know a software like VMWARE but with a best compatibility with caspar ?
thomasdesliens
 
Posts: 2
Joined: 05 May 2017, 00:46

Re: VMWARE Fusion on mac screen consumers black screen

Postby mcdikki » 18 May 2017, 15:58

There is no official recommendation for any virtulization hypervisor at all.
The critical point is, that the GPU is a important part of ccg and the additional abstraction layer introduced by the vm make things complicated, especially since the virtual gpu drivers haven't been in focus for a long time (most vms where meant to run headless servers, no need for gpu drivers). This is changing as gpu computing is gathering importance.
There have been some threads here about running ccg in a vm and the problems etc. A quick search should help.

cheers
mcdikki
sublan.tv - Wir teilen Begeisterung
User avatar
mcdikki
 
Posts: 1059
Joined: 11 Dec 2012, 15:48
Location: Germany


Return to Tech and Development

Who is online

Users browsing this forum: Google [Bot] and 4 guests