Green Lines

#1
Hi

Has anyone seen or dealt with these green lines that are appearing on my output?

I have 2x Decklink Duo 2 and I have seen this appear intermittently using drivers 10.9.5 and 10.9.10 and on both cards (they were purchased together).
I have seen the green lines on two different vision mixers. I don't know how to trigger them and they only last for between 10 seconds and 2 minutes so investigation is tricky.
Image
Startup log:

Code: Select all

[2018-01-24 11:05:25.730] [3492] [info]    ############################################################################
[2018-01-24 11:05:25.732] [3492] [info]    CasparCG Server is distributed by the Swedish Broadcasting Corporation (SVT)
[2018-01-24 11:05:25.732] [3492] [info]    under the GNU General Public License GPLv3 or higher.
[2018-01-24 11:05:25.732] [3492] [info]    Please see LICENSE.TXT for details.
[2018-01-24 11:05:25.732] [3492] [info]    http://www.casparcg.com/
[2018-01-24 11:05:25.732] [3492] [info]    ############################################################################
[2018-01-24 11:05:25.732] [3492] [info]    Starting CasparCG Video and Graphics Playout Server 2.0.7.e9fc25a Stable
[2018-01-24 11:05:25.732] [3492] [info]    on Windows Embedded Standard 
[2018-01-24 11:05:25.732] [3492] [info]    Intel(R) Core(TM) i7-4770S CPU @ 3.10GHz Physical Threads: 8
[2018-01-24 11:05:25.732] [3492] [info]    To Be Filled By O.E.M.
[2018-01-24 11:05:25.753] [3492] [info]    Decklink 10.9.10
[2018-01-24 11:05:25.789] [3492] [info]     - DeckLink Duo 2 [1]
[2018-01-24 11:05:25.789] [3492] [info]     - DeckLink Duo 2 [2]
[2018-01-24 11:05:25.789] [3492] [info]     - DeckLink Duo 2 [3]
[2018-01-24 11:05:25.789] [3492] [info]     - DeckLink Duo 2 [4]
[2018-01-24 11:05:25.789] [3492] [info]     - DeckLink Duo 2 [5]
[2018-01-24 11:05:25.789] [3492] [info]     - DeckLink Duo 2 [6]
[2018-01-24 11:05:25.789] [3492] [info]     - DeckLink Duo 2 [7]
[2018-01-24 11:05:25.789] [3492] [info]     - DeckLink Duo 2 [8]
[2018-01-24 11:05:25.791] [3492] [info]    Bluefish Not found
[2018-01-24 11:05:25.792] [3492] [info]    FreeImage 3.15.4
[2018-01-24 11:05:25.792] [3492] [info]    FFMPEG-avcodec 55.52.102
[2018-01-24 11:05:25.793] [3492] [info]    FFMPEG-avformat 55.33.100
[2018-01-24 11:05:25.793] [3492] [info]    FFMPEG-avfilter 4.2.100
[2018-01-24 11:05:25.793] [3492] [info]    FFMPEG-avutil 52.66.100
[2018-01-24 11:05:25.793] [3492] [info]    FFMPEG-swscale 2.5.102
[2018-01-24 11:05:25.793] [3492] [info]    Flash 26.0.0.131
[2018-01-24 11:05:25.797] [3492] [info]    flash[cg20.fth.pal|0] Initialized.
[2018-01-24 11:05:25.798] [3492] [info]    flash[cg20.fth.pal|0] Invoking info-command: <invoke name="GetInfo" returntype="xml"><arguments></arguments></invoke>
[2018-01-24 11:05:26.011] [3444] [info]    flash-player[cg20.fth.pal|1024x576] Initialized.
[2018-01-24 11:05:26.090] [3492] [trace]   Template-Host 2.0.4.3803 RC
[2018-01-24 11:05:26.099] [3492] [debug]   NewTek iVGA available
[2018-01-24 11:05:26.099] [3492] [info]    casparcg.config:
-----------------------------------------
<?xml version="1.0" encoding="utf-8"?>
<configuration>
   <paths>
      <media-path>D:\assets\media\</media-path>
      <log-path>log\</log-path>
      <data-path>D:\assets\data\</data-path>
      <template-path>D:\assets\templates\</template-path>
      <thumbnails-path>D:\assets\thumbnails\</thumbnails-path>
   </paths>
   <log-level>info</log-level>
   <channels>
      <channel>
         <video-mode>PAL</video-mode>
         <consumers>
            <decklink>
               <device>5</device>
            </decklink>
         </consumers>
      </channel>
      <channel>
         <video-mode>PAL</video-mode>
         <consumers>
            <decklink>
               <device>6</device>
            </decklink>
         </consumers>
      </channel>
   </channels>
   <controllers>
      <tcp>
         <port>5250</port>
         <protocol>AMCP</protocol>
      </tcp>
   </controllers>
</configuration>
-----------------------------------------
[2018-01-24 11:05:26.099] [3492] [info]    Initialized html module.
[2018-01-24 11:05:26.100] [3492] [info]    Initializing OpenGL Device.
[2018-01-24 11:05:26.128] [3312] [info]    OpenGL 4.5.0 NVIDIA 385.41 NVIDIA Corporation
[2018-01-24 11:05:26.128] [3312] [info]    Successfully initialized OpenGL Device.
[2018-01-24 11:05:26.157] [3492] [info]    Initialized ffmpeg module.
[2018-01-24 11:05:26.158] [3492] [info]    Initialized bluefish module.
[2018-01-24 11:05:26.161] [3492] [info]    Initialized decklink module.
[2018-01-24 11:05:26.161] [3492] [info]    Initialized oal module.
[2018-01-24 11:05:26.161] [3492] [info]    Initialized newtek module.
[2018-01-24 11:05:26.161] [3492] [info]    Initialized ogl module.
[2018-01-24 11:05:26.161] [3492] [info]    Initialized flash module.
[2018-01-24 11:05:26.161] [3492] [info]    Initialized image module.
[2018-01-24 11:05:26.174] [3312] [info]    [shader] Blend-modes are disabled.
[2018-01-24 11:05:26.177] [3492] [info]    video_channel[1|PAL] Successfully Initialized.
[2018-01-24 11:05:26.198] [3444] [info]    flash-player[cg20.fth.pal|1024x576] Uninitialized.
[2018-01-24 11:05:26.203] [4028] [info]    flash[cg20.fth.pal|5000] Uninitialized.
[2018-01-24 11:05:26.218] [3456] [info]    DeckLink Duo 2 [1-5|PAL] Using custom allocator.
[2018-01-24 11:05:26.219] [3456] [info]    DeckLink Duo 2 [1-5|PAL] Disabled low-latency mode.
[2018-01-24 11:05:26.219] [3456] [info]    DeckLink Duo 2 [1-5|PAL] Enabled external keyer.
[2018-01-24 11:05:26.221] [3456] [info]    DeckLink Duo 2 [1-5|PAL] Reference signal: not detected.
[2018-01-24 11:05:26.228] [3492] [info]    DeckLink Duo 2 [1-5|PAL] Successfully Initialized.
[2018-01-24 11:05:26.267] [3500] [info]    output[1] DeckLink Duo 2 [1-5|PAL] Added.
[2018-01-24 11:05:26.283] [3492] [info]    video_channel[2|PAL] Successfully Initialized.
[2018-01-24 11:05:26.317] [3656] [info]    DeckLink Duo 2 [2-6|PAL] Using custom allocator.
[2018-01-24 11:05:26.317] [3656] [info]    DeckLink Duo 2 [2-6|PAL] Disabled low-latency mode.
[2018-01-24 11:05:26.317] [3656] [info]    DeckLink Duo 2 [2-6|PAL] Enabled external keyer.
[2018-01-24 11:05:26.320] [3656] [info]    DeckLink Duo 2 [2-6|PAL] Reference signal: not detected.
[2018-01-24 11:05:26.328] [3492] [info]    DeckLink Duo 2 [2-6|PAL] Successfully Initialized.
[2018-01-24 11:05:26.363] [1308] [info]    output[2] DeckLink Duo 2 [2-6|PAL] Added.
[2018-01-24 11:05:26.363] [3492] [info]    Initialized channels.
[2018-01-24 11:05:26.364] [3492] [info]    Initialized thumbnail generator.
[2018-01-24 11:05:26.365] [3492] [info]    WinSock2 Initialized.
[2018-01-24 11:05:26.365] [3492] [info]    Listener successfully initialized
[2018-01-24 11:05:26.365] [3492] [info]    Initialized controllers.
[2018-01-24 11:05:26.365] [3492] [info]    Initialized osc.
[2018-01-24 11:05:26.365] [3492] [info]    Started initial media information retrieval.
[2018-01-24 11:05:26.493] [3368] [info]    Initial media information retrieval finished.
[2018-01-24 11:05:27.496] [1036] [info]    DeckLink Duo 2 [1-5|PAL] Reference signal: locked.
[2018-01-24 11:05:27.619] [3340] [info]    DeckLink Duo 2 [2-6|PAL] Reference signal: locked.

Re: Green Lines

#2
Hi

From my experience Duo 2 have many strange behaviors , in my case one channel some times freeze and I must restart the server then the green lines appear on the mixer I managed to remove it by unplugged the reference cable it doesn;t worked at once and some times I must do it 2-3 times until reference locked properly.