It is currently 27 Jun 2017, 04:38



screen consumer crash

Help to specific problems with your setup, or discussing CasparCG bugs

Moderators: Macey, Jonas Hummelstrand, didikunz

screen consumer crash

Postby janhein » 27 Apr 2017, 09:38

Hello,

I have installed casparcg on a windows 7 (64) pc.
I have added a screen consumer for my first display.
Everything is working well.
But when i change the screen consumer from my first display to my second display, the screen consumer is starting with a white background, and it will crach.
Why is it working on my first display, and not on my second display?

All my specs of the computer are above the system requirements of casparcg.
Also used the internal graphics card of my mainboard as well with an external graphics card. The problem is still there.

With kind regards,
Jan Hein
janhein
 
Posts: 8
Joined: 29 Apr 2016, 13:36

Re: screen consumer crash

Postby didikunz » 27 Apr 2017, 11:19

Can it be, that the main screen comes from a GPU, witch supports OpenGL, while the secondary does not?
Didi Kunz
CasparCG Client-Programmer, Template Maker & Live CG-Operator
Media Support, CH-5722 Gränichen, Switzerland http://mediasupport.ch/
Problems? Guide to posting Bug reports & Feature requests
User avatar
didikunz
 
Posts: 3478
Joined: 10 May 2010, 09:08
Location: Aarau, Switzerland

Re: screen consumer crash

Postby janhein » 27 Apr 2017, 12:52

How can I check that?

Jan Hein
janhein
 
Posts: 8
Joined: 29 Apr 2016, 13:36

Re: screen consumer crash

Postby didikunz » 27 Apr 2017, 13:14

janhein wrote:How can I check that?

Jan Hein


That is a good question :) Where did you connect the monitor cables? Did you disabled the motherboard graphics? What says the hardware controlpanel applet?
Didi Kunz
CasparCG Client-Programmer, Template Maker & Live CG-Operator
Media Support, CH-5722 Gränichen, Switzerland http://mediasupport.ch/
Problems? Guide to posting Bug reports & Feature requests
User avatar
didikunz
 
Posts: 3478
Joined: 10 May 2010, 09:08
Location: Aarau, Switzerland

Re: screen consumer crash

Postby Aston » 27 Apr 2017, 13:20

Check log file.
OK
[2014-03-14 14:31:43.797] [05149CB0] [info] OpenGL 3.3.0 NVIDIA Corporation
[2014-03-14 14:31:43.797] [05149CB0] [info] Successfully initialized OpenGL Device.
OR IF ERROR
[2014-03-14 10:19:28.349] [00EDD5C0] [info] OpenGL 1.1.0 Microsoft Corporation
[struct caspar::tag_msg_info *] = Your graphics card does not meet the minimum hardware requirements since it does not support OpenGL 3.0 or higher. CasparCG Server will not be able to continue.
User avatar
Aston
 
Posts: 59
Joined: 25 Feb 2014, 08:49
Location: Rautjärvi 60.928374, 27.105396

Re: screen consumer crash

Postby didikunz » 27 Apr 2017, 14:02

Aston wrote:Check log file.
OK
[2014-03-14 14:31:43.797] [05149CB0] [info] OpenGL 3.3.0 NVIDIA Corporation
[2014-03-14 14:31:43.797] [05149CB0] [info] Successfully initialized OpenGL Device.
OR IF ERROR
[2014-03-14 10:19:28.349] [00EDD5C0] [info] OpenGL 1.1.0 Microsoft Corporation
[struct caspar::tag_msg_info *] = Your graphics card does not meet the minimum hardware requirements since it does not support OpenGL 3.0 or higher. CasparCG Server will not be able to continue.


That seems to be the problem, you have two GPU's in your system and one is supporting OpenGL (nVidia) and one not (motherboard). I would suggest to connect the second monitor to the second out of the nVidia (they normally have two ports) and disable the internal GPU completelly. That is either done by setting a jumper or in the BIOS setup screen somewhere. Checking the motherborad's manual to see how to do this.
Didi Kunz
CasparCG Client-Programmer, Template Maker & Live CG-Operator
Media Support, CH-5722 Gränichen, Switzerland http://mediasupport.ch/
Problems? Guide to posting Bug reports & Feature requests
User avatar
didikunz
 
Posts: 3478
Joined: 10 May 2010, 09:08
Location: Aarau, Switzerland


Return to Help & Support

Who is online

Users browsing this forum: No registered users and 2 guests