It is currently 27 Jun 2017, 04:45



Sounds bug

Help to specific problems with your setup, or discussing CasparCG bugs

Moderators: Macey, Jonas Hummelstrand, didikunz

Sounds bug

Postby red455 » 24 Mar 2017, 17:53

Hi;

We use a CCG 24/24 for playing an HTML feed. It works good but after +/- 2days, the sound sounds strange . I have to restart the server to solve the problem.

Any Idea about this bug ?
red455
 
Posts: 24
Joined: 22 Sep 2015, 16:38

Re: Sounds bug

Postby didikunz » 24 Mar 2017, 18:37

red455 wrote:We use a CCG 24/24 for playing an HTML feed.


Is that a webstream or a bunch of HTML templates?
Didi Kunz
CasparCG Client-Programmer, Template Maker & Live CG-Operator
Media Support, CH-5722 Gränichen, Switzerland http://mediasupport.ch/
Problems? Guide to posting Bug reports & Feature requests
User avatar
didikunz
 
Posts: 3478
Joined: 10 May 2010, 09:08
Location: Aarau, Switzerland

Re: Sounds bug

Postby red455 » 27 Mar 2017, 14:06

It is an html page with different feed informations (from a website, from weather, ...) We have a folder with some MP3 for playing music.


Is it possible to reboot the harware and relaunch automatically Caspar + the HTML page every day at 00:00 ? It could be a solution for me
red455
 
Posts: 24
Joined: 22 Sep 2015, 16:38

Re: Sounds bug

Postby zbang » 31 Mar 2017, 04:55

Hello,

("restart the server"- just restart the Caspar server process or reboot the whole machine?)

What does "sound strange" mean? Garbled? No highs (or lows)? Noisy? Slow? Just that might lead to the root cause.
Does it happen with all the MP3 files or only certain ones?
Is the audio coming out the system audio device or embedded in an SDI signal?

You can use the windoze task scheduler to (re)start a task at a specific time although I'd probably use make a wrapper script to start Caspar and restart when it stops and then use the task scheduler to kill the Caspar proc. Consider PowerShell for this, it has ready access to all the process info. You can also use this to schedule reboots. This is still a hack workaround to the problem.

The first thing I'd do is replace the MP3 files with uncompressed audio files. Sure, they're much larger, but disk is "cheap" and it simplifies one part (the decoding) of the process. See how that works. Another option is to replace all the MP3 files with different ones and see if the problem still happens (and in the same time frame).

Oh, and if you go the restart route, don't do it at midnight, pick a random time later (00:17:07? 00:18:14?). Enough happens at midnight that tracking down bugs becomes difficult. Been there :).

Please let us know what happens.

z!
zbang
 
Posts: 44
Joined: 10 Apr 2015, 02:09


Return to Help & Support

Who is online

Users browsing this forum: No registered users and 2 guests