It is currently 28 Jun 2017, 20:07



CasparCG 2.0.7 Crash on Startup

Help to specific problems with your setup, or discussing CasparCG bugs

Moderators: Macey, Jonas Hummelstrand, didikunz

CasparCG 2.0.7 Crash on Startup

Postby jackreynolds » 29 Jan 2017, 01:05

Hello, just got a new machine to run development on and am having some issues:

Code: Select all
[2017-01-28 15:59:47.596] [6264] [info]    ############################################################################
[2017-01-28 15:59:47.604] [6264] [info]    CasparCG Server is distributed by the Swedish Broadcasting Corporation (SVT)
[2017-01-28 15:59:47.604] [6264] [info]    under the GNU General Public License GPLv3 or higher.
[2017-01-28 15:59:47.604] [6264] [info]    Please see LICENSE.TXT for details.
[2017-01-28 15:59:47.605] [6264] [info]    http://www.casparcg.com/
[2017-01-28 15:59:47.605] [6264] [info]    ############################################################################
[2017-01-28 15:59:47.605] [6264] [info]    Starting CasparCG Video and Graphics Playout Server 2.0.7.e9fc25a Stable
[2017-01-28 15:59:47.605] [6264] [info]    on Windows 10 Home
[2017-01-28 15:59:47.605] [6264] [info]    AMD Athlon(tm) X4 760K Quad Core Processor      Physical Threads: 4
[2017-01-28 15:59:47.605] [6264] [info]    MS-7721
[2017-01-28 15:59:47.612] [6264] [info]    Decklink Not found
[2017-01-28 15:59:47.614] [6264] [info]    Bluefish Not found
[2017-01-28 15:59:47.615] [6264] [info]    FreeImage 3.15.4
[2017-01-28 15:59:47.615] [6264] [info]    FFMPEG-avcodec 55.52.102
[2017-01-28 15:59:47.615] [6264] [info]    FFMPEG-avformat 55.33.100
[2017-01-28 15:59:47.616] [6264] [info]    FFMPEG-avfilter 4.2.100
[2017-01-28 15:59:47.616] [6264] [info]    FFMPEG-avutil 52.66.100
[2017-01-28 15:59:47.616] [6264] [info]    FFMPEG-swscale 2.5.102
[2017-01-28 15:59:47.616] [6264] [info]    Flash 18.0.0.203
[2017-01-28 15:59:47.619] [6264] [info]    flash[._cg20.fth.pal|0] Initialized.
[2017-01-28 15:59:47.620] [6264] [info]    flash[._cg20.fth.pal|0] Invoking info-command: <invoke name="GetInfo" returntype="xml"><arguments></arguments></invoke>
[2017-01-28 15:59:48.188] [6444] [info]    flash-player[._cg20.fth.pal|1024x576] Initialized.
[2017-01-28 15:59:48.188] [6444] [warning] flash-player[._cg20.fth.pal|1024x576] Flash call failed:<invoke name="GetInfo" returntype="xml"><arguments></arguments></invoke>
[2017-01-28 15:59:48.230] [6264] [trace]   Template-Host Unknown
[2017-01-28 15:59:48.231] [6264] [info]    NewTek iVGA unavailable (Processing.AirSend.x86.dll)
[2017-01-28 15:59:48.231] [6264] [info]    casparcg.config:
-----------------------------------------
<?xml version="1.0" encoding="utf-8"?>
<configuration>
   <paths>
      <media-path>media\</media-path>
      <log-path>log\</log-path>
      <data-path>data\</data-path>
      <template-path>templates\</template-path>
      <thumbnails-path>thumbnails\</thumbnails-path>
   </paths>
   <channels>
      <channel>
         <video-mode>PAL</video-mode>
         <consumers>
            <screen>
               <device>1</device>
            </screen>
            <system-audio/>
         </consumers>
      </channel>
   </channels>
   <controllers>
      <tcp>
         <port>5250</port>
         <protocol>AMCP</protocol>
      </tcp>
   </controllers>
</configuration>
-----------------------------------------
[2017-01-28 15:59:48.231] [6264] [info]    Initialized html module.
[2017-01-28 15:59:48.231] [6264] [info]    Initializing OpenGL Device.
[2017-01-28 15:59:48.303] [5440] [info]    OpenGL 4.5.14008 Compatibility Profile Context 21.19.137.1 ATI Technologies Inc.
[2017-01-28 15:59:48.303] [5440] [info]    Successfully initialized OpenGL Device.
[2017-01-28 15:59:48.320] [6264] [info]    Initialized ffmpeg module.
[2017-01-28 15:59:48.321] [6264] [info]    Initialized bluefish module.
[2017-01-28 15:59:48.322] [6264] [info]    Initialized decklink module.
[2017-01-28 15:59:48.323] [6264] [info]    Initialized oal module.
[2017-01-28 15:59:48.323] [6264] [info]    Initialized newtek module.
[2017-01-28 15:59:48.323] [6264] [info]    Initialized ogl module.
[2017-01-28 15:59:48.323] [6264] [info]    Initialized flash module.
[2017-01-28 15:59:48.323] [6264] [info]    Initialized image module.
[2017-01-28 15:59:48.348] [6444] [info]    flash-player[._cg20.fth.pal|1024x576] Uninitialized.
[2017-01-28 15:59:48.385] [6220] [info]    flash[._cg20.fth.pal|0] Uninitialized.
[2017-01-28 15:59:48.494] [5440] [info]    [shader] Blend-modes are disabled.
[2017-01-28 15:59:48.495] [6264] [info]    video_channel[1|PAL] Successfully Initialized.
[2017-01-28 15:59:48.501] [6264] [info]   
+---------------+
| filter_buffer |default--[720x576 64:45 bgra]--auto-inserted scaler 1:default
|   (buffer)    |
+---------------+

                                                             +-------------------+
auto-inserted scaler 0:default--[720x576 64:45 bgra]--default| filter_buffersink |
                                                             |   (buffersink)    |
                                                             +-------------------+

                                                             +-----------------+
auto-inserted scaler 1:default--[720x576 64:45 gbrp]--default| Parsed_format_0 |default--[720x576 64:45 gbrp]--Parsed_yadif_1:default
                                                             |    (format)     |
                                                             +-----------------+

                                                      +----------------+
Parsed_format_0:default--[720x576 64:45 gbrp]--default| Parsed_yadif_1 |default--[720x576 64:45 gbrp]--auto-inserted scaler 0:default
                                                      |    (yadif)     |
                                                      +----------------+

                                                     +------------------------+
Parsed_yadif_1:default--[720x576 64:45 gbrp]--default| auto-inserted scaler 0 |default--[720x576 64:45 bgra]--filter_buffersink:default
                                                     |        (scale)         |
                                                     +------------------------+

                                                    +------------------------+
filter_buffer:default--[720x576 64:45 bgra]--default| auto-inserted scaler 1 |default--[720x576 64:45 gbrp]--Parsed_format_0:default
                                                    |        (scale)         |
                                                    +------------------------+


[2017-01-28 15:59:48.502] [6264] [info]    Screen consumer [1|PAL] Successfully Initialized.
[2017-01-28 15:59:48.503] [4036] [info]    output[1] Screen consumer [1|PAL] Added.
[2017-01-28 15:59:48.612] [6932] [fatal]   #######################
 UNHANDLED EXCEPTION:
Adress:1000C5EB
Code:3221225477
Flag:0
Info:0F9AFAB8
Continuing execution.
#######################


Running Windows 10, AMD Athlon X4 760K, AMD R7 270, 8GB RAM, 1TB WD Blue HDD.

Any ideas what could be wrong? Thanks.
jackreynolds
 
Posts: 161
Joined: 02 Nov 2015, 18:02
Location: Pittsburgh, Pennsylvania, USA

Re: CasparCG 2.0.7 Crash on Startup

Postby mcdikki » 29 Jan 2017, 14:02

Seems like an error with the screen consumer.
You are running unsupported hardware. This may work, but it seems as AMDs build in GPU is not a good bet to run ccg on it. There was an other user with a similar problem a few days ago.

It seems as the screen consumer does not work with AMDs APU GPU.

cheers
mcdikki
sublan.tv - Wir teilen Begeisterung
User avatar
mcdikki
 
Posts: 1059
Joined: 11 Dec 2012, 15:48
Location: Germany

Re: CasparCG 2.0.7 Crash on Startup

Postby jackreynolds » 29 Jan 2017, 15:07

I disabled the screen consumer, but it does not seem to fix it. I noticed that it did manage to initialize my GPU:
Code: Select all
[2017-01-29 06:12:47.181] [7212] [info]    OpenGL 4.5.14008 Compatibility Profile Context 21.19.137.514 ATI Technologies Inc.
[2017-01-29 06:12:47.181] [7212] [info]    Successfully initialized OpenGL Device.


Something that was not posted in the log was that it Error: gpu_info_collector_win.cc: Can't retrieve a valid WinSAT assessment. Does this mean anything to you?

Additionally, when trying to boot 2.1.0, I get the following errors that the files are missing: MSVCP140.dll, VCRUNTIME140.dll. I remember fixing this issue before, but I don't remember how I did it? Know of what is causing these errors? Thanks.
jackreynolds
 
Posts: 161
Joined: 02 Nov 2015, 18:02
Location: Pittsburgh, Pennsylvania, USA

Re: CasparCG 2.0.7 Crash on Startup

Postby didikunz » 29 Jan 2017, 16:00

The second problem: Try installing/updateing the Visual C++ runtimes.
Didi Kunz
CasparCG Client-Programmer, Template Maker & Live CG-Operator
Media Support, CH-5722 Gränichen, Switzerland http://mediasupport.ch/
Problems? Guide to posting Bug reports & Feature requests
User avatar
didikunz
 
Posts: 3480
Joined: 10 May 2010, 09:08
Location: Aarau, Switzerland

Re: CasparCG 2.0.7 Crash on Startup

Postby jackreynolds » 29 Jan 2017, 16:37

Okay so updating those fixed it, thank you didi. I am getting a lot of the same errors that were given in 2.0.7, however 2.1.0 is successfully running.
jackreynolds
 
Posts: 161
Joined: 02 Nov 2015, 18:02
Location: Pittsburgh, Pennsylvania, USA


Return to Help & Support

Who is online

Users browsing this forum: No registered users and 3 guests