It is currently 23 Jun 2017, 09:42



KEY&FILL on 2.1

Help to specific problems with your setup, or discussing CasparCG bugs

Moderators: Macey, Jonas Hummelstrand, didikunz

KEY&FILL on 2.1

Postby philetaylor » 03 Dec 2016, 21:20

Hi.

I have been testing the 2.1 beta on one of my Caspar servers and have discovered what appears to be a bug (or feature). The server has a Decklink 4k Extreme for key & fill.

The key doesn't seem to be working properly though. When I load a .jpg image I am used to it NOT being transparent but that doesn't seem to be the case with 2.1. When I look at the key channel, I would expect it to be solid white when showing an image without transparency like a .jpg but it is actually a greyscale of the image so light sections of the image are disappearing. The same happens with html/flash templates that are usually solid so it isn't specific to .jpg.

I am using the decklink as key/fill inputs to a DSK on an ATEM switcher with pre-multiplied key enabled (nothing has changed for quite some time).

I am also using the latest version of the Decklink drivers (downloaded a couple of days ago).

Any ideas?

Phil
philetaylor
 
Posts: 16
Joined: 18 Jan 2014, 14:45

Re: KEY&FILL on 2.1

Postby drakmor » 05 Dec 2016, 08:52

Check this - viewtopic.php?p=25779#p25779 settings
drakmor
 
Posts: 16
Joined: 13 Mar 2016, 16:49
Location: Kazan / Russia

Re: KEY&FILL on 2.1

Postby didikunz » 05 Dec 2016, 12:35

drakmor wrote:Check this - viewtopic.php?p=25779#p25779 settings

This is about another card.

Can you post the config file?
Didi Kunz
CasparCG Client-Programmer, Template Maker & Live CG-Operator
Media Support, CH-5722 Gränichen, Switzerland http://mediasupport.ch/
Problems? Guide to posting Bug reports & Feature requests
User avatar
didikunz
 
Posts: 3477
Joined: 10 May 2010, 09:08
Location: Aarau, Switzerland

Re: KEY&FILL on 2.1

Postby philetaylor » 05 Dec 2016, 16:10

Yes no problem!

The server also contains a DeckLink Duo which is detected as devices 1&2 with the Extreme as 3. I have included the whole startup log which I thought might be helpful?

Thanks for having a look at this as it has me stumped!

Code: Select all
[2016-12-03 15:00:38.397] [2796] [info]    Starting CasparCG Video and Graphics Playout Server 2.1.0.92e13a8 Beta 1
[2016-12-03 15:00:38.397] [2796] [info]    on Windows 7 Professional Service Pack 1
[2016-12-03 15:00:38.397] [2796] [info]    Intel(R) Core(TM) i7-3820 CPU @ 3.60GHz Physical Threads: 8
[2016-12-03 15:00:38.397] [2796] [info]    System Product Name
[2016-12-03 15:00:38.397] [2796] [info]    Initialized reroute module.
[2016-12-03 15:00:38.397] [2796] [info]    Initialized ffmpeg module.
[2016-12-03 15:00:38.397] [2796] [info]    Initialized oal module.
[2016-12-03 15:00:38.603] [2796] [info]    Initialized bluefish module.
[2016-12-03 15:00:38.603] [2796] [info]    Initialized decklink module.
[2016-12-03 15:00:38.603] [2796] [info]    Initialized screen module.
[2016-12-03 15:00:38.629] [2796] [info]    Initialized html module.
[2016-12-03 15:00:38.629] [2796] [info]    Initialized psd module.
[2016-12-03 15:00:38.645] [2796] [info]    Initialized flash module.
[2016-12-03 15:00:38.645] [2796] [info]    Initialized newtek module.
[2016-12-03 15:00:38.645] [2796] [info]    Initialized image module.
[2016-12-03 15:00:38.756] [2796] [info]    ffmpeg.avcodec 56.41.100
[2016-12-03 15:00:38.756] [2796] [info]    ffmpeg.avformat 56.36.100
[2016-12-03 15:00:38.756] [2796] [info]    ffmpeg.avfilter 5.16.101
[2016-12-03 15:00:38.756] [2796] [info]    ffmpeg.avutil 54.27.100
[2016-12-03 15:00:38.756] [2796] [info]    ffmpeg.swscale 3.1.101
[2016-12-03 15:00:38.756] [2796] [info]    bluefish.version Not found
[2016-12-03 15:00:38.756] [2796] [info]    decklink.version 10.8.4
[2016-12-03 15:00:38.757] [2796] [info]    decklink.device DeckLink SDI [1]
[2016-12-03 15:00:38.757] [2796] [info]    decklink.device DeckLink SDI [2]
[2016-12-03 15:00:38.757] [2796] [info]    decklink.device DeckLink 4K Extreme [3]
[2016-12-03 15:00:38.757] [2796] [info]    cef.version 3.1750.1805
[2016-12-03 15:00:38.757] [2796] [info]    cef.chromeversion 33.0.1750.170
[2016-12-03 15:00:38.757] [2796] [info]    flash 11.8.800.94
[2016-12-03 15:00:38.757] [2796] [info]    newtek-ivga.version unavailable (Processing.AirSend.x64.dll)
[2016-12-03 15:00:38.757] [2796] [info]    freeimage 3.16.0
[2016-12-03 15:00:38.757] [2796] [info]    casparcg.config:
[2016-12-03 15:00:38.757] [2796] [info]    -----------------------------------------
[2016-12-03 15:00:38.757] [2796] [info]    <?xml version="1.0" encoding="utf-8"?>
[2016-12-03 15:00:38.757] [2796] [info]    <configuration>
[2016-12-03 15:00:38.757] [2796] [info]       <paths>
[2016-12-03 15:00:38.757] [2796] [info]          <media-path>e:\media\</media-path>
[2016-12-03 15:00:38.757] [2796] [info]          <log-path>e:\log\</log-path>
[2016-12-03 15:00:38.757] [2796] [info]          <data-path>e:\data\</data-path>
[2016-12-03 15:00:38.757] [2796] [info]          <template-path>e:\templates\</template-path>
[2016-12-03 15:00:38.757] [2796] [info]          <thumbnail-path>e:\thumbnails\</thumbnail-path>
[2016-12-03 15:00:38.757] [2796] [info]       </paths>
[2016-12-03 15:00:38.757] [2796] [info]       <log-level>info</log-level>
[2016-12-03 15:00:38.757] [2796] [info]       <thumbnails>
[2016-12-03 15:00:38.757] [2796] [info]          <video-mode>1080i5000</video-mode>
[2016-12-03 15:00:38.757] [2796] [info]       </thumbnails>
[2016-12-03 15:00:38.757] [2796] [info]       <channels>
[2016-12-03 15:00:38.757] [2796] [info]          <channel>
[2016-12-03 15:00:38.757] [2796] [info]             <video-mode>1080i5000</video-mode>
[2016-12-03 15:00:38.757] [2796] [info]             <consumers>
[2016-12-03 15:00:38.757] [2796] [info]                <decklink>
[2016-12-03 15:00:38.757] [2796] [info]                   <device>3</device>
[2016-12-03 15:00:38.757] [2796] [info]                   <embedded-audio>true</embedded-audio>
[2016-12-03 15:00:38.757] [2796] [info]                   <channel-layout>stereo</channel-layout>
[2016-12-03 15:00:38.757] [2796] [info]                   <latency>low</latency>
[2016-12-03 15:00:38.757] [2796] [info]                   <keyer>external</keyer>
[2016-12-03 15:00:38.757] [2796] [info]                   <buffer-depth>3</buffer-depth>
[2016-12-03 15:00:38.757] [2796] [info]                   <custom-allocator>true</custom-allocator>
[2016-12-03 15:00:38.757] [2796] [info]                </decklink>
[2016-12-03 15:00:38.757] [2796] [info]             </consumers>
[2016-12-03 15:00:38.757] [2796] [info]          </channel>
[2016-12-03 15:00:38.757] [2796] [info]          <channel>
[2016-12-03 15:00:38.757] [2796] [info]             <video-mode>1080i5000</video-mode>
[2016-12-03 15:00:38.757] [2796] [info]             <consumers>
[2016-12-03 15:00:38.757] [2796] [info]                <decklink>
[2016-12-03 15:00:38.757] [2796] [info]                   <device>1</device>
[2016-12-03 15:00:38.757] [2796] [info]                   <latency>low</latency>
[2016-12-03 15:00:38.757] [2796] [info]                   <key-device>2</key-device>
[2016-12-03 15:00:38.757] [2796] [info]                </decklink>
[2016-12-03 15:00:38.757] [2796] [info]                <decklink>
[2016-12-03 15:00:38.757] [2796] [info]                   <device>2</device>
[2016-12-03 15:00:38.757] [2796] [info]                   <latency>low</latency>
[2016-12-03 15:00:38.757] [2796] [info]                   <keyer>default</keyer>
[2016-12-03 15:00:38.757] [2796] [info]                   <key-only>true</key-only>
[2016-12-03 15:00:38.757] [2796] [info]                </decklink>
[2016-12-03 15:00:38.757] [2796] [info]             </consumers>
[2016-12-03 15:00:38.757] [2796] [info]          </channel>
[2016-12-03 15:00:38.757] [2796] [info]          <channel>
[2016-12-03 15:00:38.757] [2796] [info]             <video-mode>PAL</video-mode>
[2016-12-03 15:00:38.757] [2796] [info]             <consumers>
[2016-12-03 15:00:38.757] [2796] [info]                <screen>
[2016-12-03 15:00:38.757] [2796] [info]                   <device>1</device>
[2016-12-03 15:00:38.757] [2796] [info]                   <windowed>false</windowed>
[2016-12-03 15:00:38.757] [2796] [info]                </screen>
[2016-12-03 15:00:38.757] [2796] [info]             </consumers>
[2016-12-03 15:00:38.757] [2796] [info]          </channel>
[2016-12-03 15:00:38.757] [2796] [info]       </channels>
[2016-12-03 15:00:38.757] [2796] [info]       <controllers>
[2016-12-03 15:00:38.757] [2796] [info]          <tcp>
[2016-12-03 15:00:38.757] [2796] [info]             <port>5250</port>
[2016-12-03 15:00:38.757] [2796] [info]             <protocol>AMCP</protocol>
[2016-12-03 15:00:38.757] [2796] [info]          </tcp>
[2016-12-03 15:00:38.757] [2796] [info]       </controllers>
[2016-12-03 15:00:38.757] [2796] [info]    </configuration>
[2016-12-03 15:00:38.757] [2796] [info]    -----------------------------------------
[2016-12-03 15:00:38.758] [2796] [info]    Initialized audio config.
[2016-12-03 15:00:38.759] [2796] [info]    Initializing OpenGL Device.
[2016-12-03 15:00:39.087] [2796] [info]    Successfully initialized OpenGL 4.5.0 NVIDIA 368.39 NVIDIA Corporation
[2016-12-03 15:00:39.092] [2796] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 1
[2016-12-03 15:00:39.093] [2796] [info]    video_channel[1|1080i5000] Successfully Initialized.
[2016-12-03 15:00:39.093] [2796] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 2
[2016-12-03 15:00:39.094] [2796] [info]    video_channel[2|1080i5000] Successfully Initialized.
[2016-12-03 15:00:39.094] [2796] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 3
[2016-12-03 15:00:39.095] [2796] [info]    video_channel[3|PAL] Successfully Initialized.
[2016-12-03 15:00:39.214] [4704] [info]    DeckLink 4K Extreme [1-3|1080i5000] Enabled embedded-audio.
[2016-12-03 15:00:39.214] [4704] [info]    DeckLink 4K Extreme [1-3|1080i5000] Enabled low-latency mode.
[2016-12-03 15:00:39.214] [4704] [info]    DeckLink 4K Extreme [1-3|1080i5000] Enabled external keyer.
[2016-12-03 15:00:39.243] [2796] [info]    DeckLink 4K Extreme [1-3|1080i5000] Initialized.
[2016-12-03 15:00:39.298] [872]  [warning] Device does not support video-format: 1080i50
[2016-12-03 15:00:39.300] [872]  [info]    DeckLink SDI [2-1|1080i5000] Enabled low-latency mode.
[2016-12-03 15:00:39.300] [872]  [error]   DeckLink SDI [2-1|1080i5000] Failed to enable external keyer.
[2016-12-03 15:00:39.326] [5200] [info]    DeckLink 4K Extreme [1-3|1080i5000] Reference signal: not detected.
[2016-12-03 15:00:39.352] [2796] [info]    DeckLink SDI [2-1|1080i5000] Initialized.
[2016-12-03 15:00:39.417] [3712] [warning] Device does not support video-format: 1080i50
[2016-12-03 15:00:39.418] [3712] [info]    DeckLink SDI [2-2|1080i5000] Enabled low-latency mode.
[2016-12-03 15:00:39.418] [3712] [error]   DeckLink SDI [2-2|1080i5000] Failed to enable external keyer.
[2016-12-03 15:00:39.473] [2796] [info]    DeckLink SDI [2-2|1080i5000] Initialized.
[2016-12-03 15:00:39.488] [2932] [info]    DeckLink SDI [2-1|1080i5000] Reference signal: not detected.
[2016-12-03 15:00:39.497] [2796] [info]    Screen consumer [3|PAL] Initialized.
[2016-12-03 15:00:39.497] [2796] [info]    Initialized channels.
[2016-12-03 15:00:39.497] [2796] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 0
[2016-12-03 15:00:39.498] [2796] [info]    Initialized thumbnail generator.
[2016-12-03 15:00:39.499] [2796] [info]    Initialized controllers.
[2016-12-03 15:00:39.499] [2796] [info]    Initialized osc.
[2016-12-03 15:00:39.499] [2796] [info]    Started initial media information retrieval.
[2016-12-03 15:00:39.556] [4404] [error]   Dynamic exception type: class std::runtime_error
[2016-12-03 15:00:39.556] [4404] [error]   std::exception::what: File not relative to folder
[2016-12-03 15:00:39.556] [4404] [error]   Caught at (polling_filesystem_monitor):
[2016-12-03 15:00:39.556] [4404] [error]   
[2016-12-03 15:00:39.556] [4404] [error]       c:\program files (x86)\jenkins\jobs\casparcg_server_2.1.0\workspace\common\polling_filesystem_monitor.cpp (61): `caspar::exception_protected_handler::operator()'::`1'::catch$1
[2016-12-03 15:00:39.556] [4404] [error]       000007FEF947C710 (VCRUNTIME140): (filename not available): _C_specific_handler
[2016-12-03 15:00:39.556] [4404] [error]       000007FEF9472AC2 (VCRUNTIME140): (filename not available): _FrameUnwindFilter
[2016-12-03 15:00:39.556] [4404] [error]       00000000776FB681 (ntdll): (filename not available): RtlRestoreContext
[2016-12-03 15:00:39.556] [4404] [error]       c:\program files (x86)\jenkins\jobs\casparcg_server_2.1.0\workspace\common\polling_filesystem_monitor.cpp (57): caspar::exception_protected_handler::operator()
[2016-12-03 15:00:39.556] [4404] [error]       c:\program files (x86)\jenkins\jobs\casparcg_server_2.1.0\workspace\common\polling_filesystem_monitor.cpp (173): caspar::directory_monitor::scan
[2016-12-03 15:00:39.556] [4404] [error]       c:\program files (x86)\jenkins\jobs\casparcg_server_2.1.0\workspace\common\polling_filesystem_monitor.cpp (316): caspar::polling_filesystem_monitor::scan
[2016-12-03 15:00:39.556] [4404] [error]       c:\program files (x86)\microsoft visual studio 14.0\vc\include\functional (209): std::_Func_impl<<lambda_55d171a33d46433adc83b70a83aecdab>,std::allocator<int>,void>::_Do_call
[2016-12-03 15:00:39.556] [4404] [error]       c:\program files (x86)\microsoft visual studio 14.0\vc\include\future (750): std::_Packaged_state<void __cdecl(void)>::_Call_immediate
[2016-12-03 15:00:39.556] [4404] [error]       c:\program files (x86)\jenkins\jobs\casparcg_server_2.1.0\workspace\common\executor.h (234): <lambda_ee95ee952128b729e13d6ab0e388d2bf>::operator()
[2016-12-03 15:00:39.556] [4404] [error]       c:\program files (x86)\jenkins\jobs\casparcg_server_2.1.0\workspace\common\executor.h (286): caspar::executor::run
[2016-12-03 15:00:39.556] [4404] [error]       00000001401AE583 (casparcg): (filename not available): boost::detail::shared_count::swap
[2016-12-03 15:00:39.556] [4404] [error]       000007FEEFD6BE1D (ucrtbase): (filename not available): crt_at_quick_exit
[2016-12-03 15:00:39.556] [4404] [error]       00000000775A59CD (kernel32): (filename not available): BaseThreadInitThunk
[2016-12-03 15:00:39.556] [4404] [error]       00000000776DA561 (ntdll): (filename not available): RtlUserThreadStart
[2016-12-03 15:00:39.556] [4404] [error]   
[2016-12-03 15:00:39.609] [4776] [info]    DeckLink SDI [2-2|1080i5000] Reference signal: not detected.
philetaylor
 
Posts: 16
Joined: 18 Jan 2014, 14:45

Re: KEY&FILL on 2.1

Postby philetaylor » 07 Dec 2016, 18:20

Hi.

I am planning to spend some time trying to diagnose this problem tomorrow but I noticed a recent commit with the description: "Fixed bug in the contrast/saturation/brightness code where the wrong luma coefficients was used."

I wonder it this is the cause of my problem or something completely different?

Thanks

Phil
philetaylor
 
Posts: 16
Joined: 18 Jan 2014, 14:45

Re: KEY&FILL on 2.1

Postby philetaylor » 07 Dec 2016, 18:24

After reading the details of the bug, I suspect it isn't my problem as this is from 2013!
philetaylor
 
Posts: 16
Joined: 18 Jan 2014, 14:45

Re: KEY&FILL on 2.1

Postby philetaylor » 08 Dec 2016, 12:40

Just as a follow-up to this. Today I tried the latest nightly build and that was exactly the same as Beta 1 so I tried downgrading BMD Desktop Video. I had 10.7.1 to hand so I installed that and the problem disappeared!

If I get a chance I will try progressively upgrading until the problem comes back but I suspect it is something introduced in 10.8.4?

Thanks

Phil
philetaylor
 
Posts: 16
Joined: 18 Jan 2014, 14:45


Return to Help & Support

Who is online

Users browsing this forum: No registered users and 1 guest