It is currently 27 Jun 2017, 04:40



video playout 2xfast in Caspar Client with Ultrastudio 4k

Help to specific problems with your setup, or discussing CasparCG bugs

Moderators: Macey, Jonas Hummelstrand, didikunz

video playout 2xfast in Caspar Client with Ultrastudio 4k

Postby cris » 13 Sep 2016, 13:58

Hello everybody.
I have been playing with Caspar for the few last days and learning from the forums as much as I can.
I think I noticed now is that when playing videos with the Caspar Client the videos go twice as fast with the config file set to screen and Ultrastudio 4k device.
As soon as I delete the Ultrastudio from the config it plays fine on the screen consumer.

Then, with the Ultrastudio in the config and using the NAVIS Football client (great stuff!) the animations play at normal speed and even having the fill and key in separate outputs.
So, is it the Caspar Client doing this ?
Thanks,
Cris

This is the channel config:
Code: Select all
<channels>
<channel>
<video-mode>1080i5000</video-mode>
<consumers>
<screen>
<device>1</device>
</screen>
<system-audio />
<decklink>
<device>1</device>
</decklink>
</consumers>
</channel>
Running Windows 10 Pro
MacBook Pro 15 inch Mid 2015
Processor: 2,8 Ghz Intel Core i7
Memory 16 GB 1600 Mhz DDR3
Graphics: Intel Iris Pro 1536 MB /AMD Radeon R9 M370X
BMD UltraStudio 4K
cris
 
Posts: 5
Joined: 24 May 2016, 22:25

Re: video playout 2xfast in Caspar Client with Ultrastudio 4

Postby mk7ita » 13 Sep 2016, 18:13

Hi cris,

I had same problems with a Quicktime movie with Apple Pro Res codec.
They started to play fine when I changed the codec (to h264 100Mbps).

The fast videos worked fine on another pc (win7 based) but not on the last one I made (win 10 based).

I can't give you more infos cause I still didn't tracked down why it happens.

Matteo
mk7ita
 
Posts: 5
Joined: 30 Aug 2016, 18:06

Re: video playout 2xfast in Caspar Client with Ultrastudio 4

Postby cris » 14 Sep 2016, 10:36

Thanks Matteo,
I did try different videos, myown, an MPEG4 file, and even the video fiales that are already in Casper, the AMB video, the wipe, all of it...
The one thing I did last week is to try the Server front end software, which crashed everytime and never worked so I deleted it...
Running Windows 10 Pro
MacBook Pro 15 inch Mid 2015
Processor: 2,8 Ghz Intel Core i7
Memory 16 GB 1600 Mhz DDR3
Graphics: Intel Iris Pro 1536 MB /AMD Radeon R9 M370X
BMD UltraStudio 4K
cris
 
Posts: 5
Joined: 24 May 2016, 22:25

Re: video playout 2xfast in Caspar Client with Ultrastudio 4

Postby mk7ita » 15 Sep 2016, 13:23

Here is my channel setup in the config file:

Code: Select all
    <channel>
      <video-mode>1080i5000</video-mode>
      <consumers>
        <decklink>
          <device>1</device>
          <embedded-audio>true]</embedded-audio>
          <keyer>external</keyer>
          <buffer-depth>3</buffer-depth>
        </decklink>
      </consumers>
    </channel>


I didn't use the screen consumer, maybe you can try to remove that 3 lines from your and see if in some way it works fine.
Or you can try to put the screen device lines under the decklink lines so the decklink became the master and manage better the playout frequency.
mk7ita
 
Posts: 5
Joined: 30 Aug 2016, 18:06

Re: video playout 2xfast in Caspar Client with Ultrastudio 4

Postby Jesper Stærkær » 15 Sep 2016, 16:22

This is probably a driver-issue. Please try Decklink drivers 10.7.0 and the lastet CasparCG version 2.1-build from builds.casparcg.com.

I'm not sure this solves the problem, but it might be worth a try. I'm sorry I don't have the hardware to reproduce and troubleshoot at the moment.
Jesper Stærkær
Independent Consultant at SuperFly.tv
User avatar
Jesper Stærkær
 
Posts: 853
Joined: 13 Apr 2010, 18:06
Location: Trondheim, Norway

Re: video playout 2xfast in Caspar Client with Ultrastudio 4

Postby cris » 20 Sep 2016, 12:04

Hi guys,
Thanks for the replies.
Yes, I just uninstalled the drivers for the Ultrastudio and installed the latest ones (released on september 9 from BMD) and now is working just fine.
Notice that I did have the same driver versin installed in the pc, the same one I reinstalled.
Regards,
Cris
Running Windows 10 Pro
MacBook Pro 15 inch Mid 2015
Processor: 2,8 Ghz Intel Core i7
Memory 16 GB 1600 Mhz DDR3
Graphics: Intel Iris Pro 1536 MB /AMD Radeon R9 M370X
BMD UltraStudio 4K
cris
 
Posts: 5
Joined: 24 May 2016, 22:25

Re: video playout 2xfast in Caspar Client with Ultrastudio 4

Postby Jesper Stærkær » 20 Sep 2016, 13:15

Decklink drivers 10.8 are said to fix this. Please test and report back.
Jesper Stærkær
Independent Consultant at SuperFly.tv
User avatar
Jesper Stærkær
 
Posts: 853
Joined: 13 Apr 2010, 18:06
Location: Trondheim, Norway

Re: video playout 2xfast in Caspar Client with Ultrastudio 4

Postby ian morton » 03 Jun 2017, 08:10

Thanks for the script for setup earlier here. I have an Ultrastudio HD Mini and that worked perfectly straight away. Gives key and fill if no background on the web page. Decklink drivers 10.9.3.
ian morton
 
Posts: 5
Joined: 01 Jun 2017, 05:50


Return to Help & Support

Who is online

Users browsing this forum: Bing [Bot] and 3 guests