It is currently 28 Apr 2017, 07:17



Slow playback on UltraStudio Mini Monitor @ PAL frame rates

Help to specific problems with your setup, or discussing CasparCG bugs

Moderators: Macey, Jonas Hummelstrand, didikunz

Slow playback on UltraStudio Mini Monitor @ PAL frame rates

Postby FlyOntheWall » 05 Sep 2016, 19:02

Hi all,

We recently purchased a Intel NUC as a small form factor CasparCG playout device. We connected a BM UltraStudio Mini Monitor via Thunderbolt. When we set Caspar to output 59.94 frame rates, everything works great but when we set it to 25p or 50i everything plays really slow, perhaps 1/4 speed. If set to Screen consumer only, 25p/50i work fine.

This same video file (1080p25 ProRes 422) plays fine on another CasparCG server, outputting to a Decklink Card.

I exchanged the Mini Monitor thinking it might be faulty but a new unit behaves the same.

Many thanks for any help you can provide.



Server: 2.0.7.aecd9cf Stable
Desktop Video: 10.7
OS: Win 10

Log:
Code: Select all
[2016-09-05 18:56:33.805] [7268] [info]    ############################################################################
[2016-09-05 18:56:33.805] [7268] [info]    CasparCG Server is distributed by the Swedish Broadcasting Corporation (SVT)
[2016-09-05 18:56:33.805] [7268] [info]    under the GNU General Public License GPLv3 or higher.
[2016-09-05 18:56:33.805] [7268] [info]    Please see LICENSE.TXT for details.
[2016-09-05 18:56:33.805] [7268] [info]    http://www.casparcg.com/
[2016-09-05 18:56:33.805] [7268] [info]    ############################################################################
[2016-09-05 18:56:33.805] [7268] [info]    Starting CasparCG Video and Graphics Playout Server 2.0.7.aecd9cf Stable
[2016-09-05 18:56:33.805] [7268] [info]    on Windows 10 Pro
[2016-09-05 18:56:33.806] [7268] [info]    Intel(R) Core(TM) i7-6770HQ CPU @ 2.60GHz Physical Threads: 8
[2016-09-05 18:56:33.806] [7268] [info]   
[2016-09-05 18:56:33.827] [7268] [info]    Decklink 10.7
[2016-09-05 18:56:33.856] [7268] [info]     - UltraStudio Mini Monitor [1]
[2016-09-05 18:56:33.856] [7268] [info]    Bluefish Not found
[2016-09-05 18:56:33.857] [7268] [info]    FreeImage 3.15.4
[2016-09-05 18:56:33.857] [7268] [info]    FFMPEG-avcodec 55.52.102
[2016-09-05 18:56:33.857] [7268] [info]    FFMPEG-avformat 55.33.100
[2016-09-05 18:56:33.857] [7268] [info]    FFMPEG-avfilter 4.2.100
[2016-09-05 18:56:33.857] [7268] [info]    FFMPEG-avutil 52.66.100
[2016-09-05 18:56:33.857] [7268] [info]    FFMPEG-swscale 2.5.102
[2016-09-05 18:56:33.857] [7268] [info]    Flash 18.0.0.203
[2016-09-05 18:56:33.858] [7268] [info]    flash[cg20.fth.pal|0] Initialized.
[2016-09-05 18:56:33.858] [7268] [info]    flash[cg20.fth.pal|0] Invoking info-command: <invoke name="GetInfo" returntype="xml"><arguments></arguments></invoke>
[2016-09-05 18:56:33.930] [1840] [debug]   flash-player[cg20.fth.pal|1024x576] [command]      <invoke name="OnCommand" returntype="xml"><arguments><string>Command recieved @GetInfo@?@</string></arguments></invoke>
[2016-09-05 18:56:33.955] [1840] [info]    flash-player[cg20.fth.pal|1024x576] Initialized.
[2016-09-05 18:56:33.956] [1840] [debug]   flash-player[cg20.fth.pal|1024x576] [command]      <invoke name="OnCommand" returntype="xml"><arguments><string>Command recieved @GetInfo@?@</string></arguments></invoke>
[2016-09-05 18:56:34.031] [7268] [trace]   Template-Host 2.0.4.3803 RC
[2016-09-05 18:56:34.031] [7268] [info]    NewTek iVGA unavailable (Processing.AirSend.x86.dll)
[2016-09-05 18:56:34.031] [7268] [info]    casparcg.config:
-----------------------------------------
<?xml version="1.0" encoding="utf-8"?>
<configuration>
   <paths>
      <media-path>C:\Users\fotw\Videos\</media-path>
      <log-path>log\</log-path>
      <data-path>data\</data-path>
      <template-path>templates\</template-path>
      <thumbnails-path>thumbnails\</thumbnails-path>
   </paths>
   <channels>
      <channel>
         <video-mode>1080i5000</video-mode>
         <consumers>
            <decklink>
               <device>1</device>
               <embedded-audio>true</embedded-audio>
               <buffer-depth>4</buffer-depth>
            </decklink>
            <screen>
               <device>1</device>
               <auto-deinterlace>false</auto-deinterlace>
            </screen>
         </consumers>
      </channel>
   </channels>
   <controllers>
      <tcp>
         <port>5250</port>
         <protocol>AMCP</protocol>
      </tcp>
   </controllers>
</configuration>
-----------------------------------------
[2016-09-05 18:56:34.031] [7268] [info]    Initialized html module.
[2016-09-05 18:56:34.031] [7268] [info]    Initializing OpenGL Device.
[2016-09-05 18:56:34.042] [8160] [info]    OpenGL 4.4.0 - Build 21.20.16.4481 Intel
[2016-09-05 18:56:34.042] [8160] [info]    Successfully initialized OpenGL Device.
[2016-09-05 18:56:34.047] [7268] [info]    Initialized ffmpeg module.
[2016-09-05 18:56:34.047] [7268] [info]    Initialized bluefish module.
[2016-09-05 18:56:34.066] [7268] [info]    Initialized decklink module.
[2016-09-05 18:56:34.066] [7268] [info]    Initialized oal module.
[2016-09-05 18:56:34.066] [7268] [info]    Initialized newtek module.
[2016-09-05 18:56:34.066] [7268] [info]    Initialized ogl module.
[2016-09-05 18:56:34.066] [7268] [info]    Initialized flash module.
[2016-09-05 18:56:34.066] [7268] [info]    Initialized image module.
[2016-09-05 18:56:34.087] [8160] [info]    [shader] Blend-modes are disabled.
[2016-09-05 18:56:34.087] [7268] [warning] [image_mixer] TextureBarrierNV not supported. Post processing will not be available
[2016-09-05 18:56:34.088] [7268] [info]    video_channel[1|1080i5000] Successfully Initialized.
[2016-09-05 18:56:34.136] [1840] [info]    flash-player[cg20.fth.pal|1024x576] Uninitialized.
[2016-09-05 18:56:34.139] [3464] [info]    flash[cg20.fth.pal|5000] Uninitialized.
[2016-09-05 18:56:34.160] [7988] [warning] Device does not support video-format: 1214854448
[2016-09-05 18:56:34.160] [7988] [info]    UltraStudio Mini Monitor [1-1|1080i5000] Using custom allocator.
[2016-09-05 18:56:34.161] [7988] [info]    UltraStudio Mini Monitor [1-1|1080i5000] Enabled embedded-audio.
[2016-09-05 18:56:34.161] [7988] [info]    UltraStudio Mini Monitor [1-1|1080i5000] Disabled low-latency mode.
[2016-09-05 18:56:34.161] [7988] [error]   UltraStudio Mini Monitor [1-1|1080i5000] Failed to enable external keyer.
[2016-09-05 18:56:34.177] [7988] [debug]   UltraStudio Mini Monitor [1-1|1080i5000] allocated buffer of size: 4147200 for a total of 4147200
[2016-09-05 18:56:34.179] [7988] [info]    UltraStudio Mini Monitor [1-1|1080i5000] Reference signal: not supported by hardware.
[2016-09-05 18:56:34.197] [7988] [debug]   UltraStudio Mini Monitor [1-1|1080i5000] allocated buffer of size: 4147200 for a total of 8294400
[2016-09-05 18:56:34.215] [7988] [debug]   UltraStudio Mini Monitor [1-1|1080i5000] allocated buffer of size: 4147200 for a total of 12441600
[2016-09-05 18:56:34.234] [7988] [debug]   UltraStudio Mini Monitor [1-1|1080i5000] allocated buffer of size: 4147200 for a total of 16588800
[2016-09-05 18:56:34.253] [7988] [debug]   UltraStudio Mini Monitor [1-1|1080i5000] allocated buffer of size: 4147200 for a total of 20736000
[2016-09-05 18:56:34.273] [7988] [debug]   UltraStudio Mini Monitor [1-1|1080i5000] allocated buffer of size: 4147200 for a total of 24883200
[2016-09-05 18:56:34.275] [7268] [info]    UltraStudio Mini Monitor [1-1|1080i5000] Successfully Initialized.
[2016-09-05 18:56:34.297] [7984] [info]    output[1] UltraStudio Mini Monitor [1-1|1080i5000] Added.
[2016-09-05 18:56:34.300] [7268] [info]   
+---------------+
| filter_buffer |default--[1920x1080 1:1 bgra]--filter_buffersink:default
|   (buffer)    |
+---------------+

                                                    +-------------------+
filter_buffer:default--[1920x1080 1:1 bgra]--default| filter_buffersink |
                                                    |   (buffersink)    |
                                                    +-------------------+


[2016-09-05 18:56:34.301] [7268] [info]    Screen consumer [1|1080i5000] Successfully Initialized.
[2016-09-05 18:56:34.304] [7984] [info]    output[1] Screen consumer [1|1080i5000] Added.
[2016-09-05 18:56:34.304] [7268] [info]    Initialized channels.
[2016-09-05 18:56:34.306] [7268] [warning] [image_mixer] TextureBarrierNV not supported. Post processing will not be available
[2016-09-05 18:56:34.308] [7268] [info]    Initialized thumbnail generator.
[2016-09-05 18:56:34.308] [7268] [info]    WinSock2 Initialized.
[2016-09-05 18:56:34.308] [7268] [info]    Listener successfully initialized
[2016-09-05 18:56:34.308] [7268] [info]    Initialized controllers.
[2016-09-05 18:56:34.308] [7268] [info]    Initialized osc.
[2016-09-05 18:56:34.309] [7268] [info]    Started initial media information retrieval.
[2016-09-05 18:56:34.364] [8332] [info]    Screen consumer [1|1080i5000] Successfully Initialized.
[2016-09-05 18:56:34.510] [7332] [info]    Initial media information retrieval finished.
[2016-09-05 18:56:34.645] [8328] [info]    Accepted connection from 127.0.0.1 2
[2016-09-05 18:56:34.645] [8328] [info]    Received message from 127.0.0.1: VERSION SERVER\r\n
[2016-09-05 18:56:34.645] [7768] [debug]   Executed command: VersionCommand
[2016-09-05 18:56:34.645] [7768] [info]    Sent message to 127.0.0.1: 201 VERSION OK\r\n2.0.7.aecd9cf Stable\r\n
[2016-09-05 18:56:34.650] [8328] [info]    Received message from 127.0.0.1: INFO\r\n
[2016-09-05 18:56:34.650] [7768] [debug]   Executed command: InfoCommand
[2016-09-05 18:56:34.650] [7768] [info]    Sent message to 127.0.0.1: 200 INFO OK\r\n1 1080i5000 PLAYING\r\n\r\n
[2016-09-05 18:56:34.653] [8328] [info]    Received message from 127.0.0.1: CLS\r\n
[2016-09-05 18:56:34.656] [7768] [debug]   Executed command: ClsCommand
[2016-09-05 18:56:34.656] [7768] [info]    Sent more than 512 bytes to 127.0.0.1
[2016-09-05 18:56:34.656] [8328] [info]    Received message from 127.0.0.1: TLS\r\n
[2016-09-05 18:56:34.661] [8328] [info]    Received message from 127.0.0.1: DATA LIST\r\n
[2016-09-05 18:56:34.661] [7768] [debug]   Executed command: TlsCommand
[2016-09-05 18:56:34.661] [7768] [info]    Sent more than 512 bytes to 127.0.0.1
[2016-09-05 18:56:34.661] [7768] [debug]   Executed command: DataCommand
[2016-09-05 18:56:34.661] [7768] [info]    Sent message to 127.0.0.1: 200 DATA LIST OK\r\n\r\n
[2016-09-05 18:56:34.663] [8328] [info]    Received message from 127.0.0.1: THUMBNAIL LIST\r\n
[2016-09-05 18:56:34.665] [7768] [debug]   Executed command: ThumbnailCommand
[2016-09-05 18:56:34.665] [7768] [info]    Sent more than 512 bytes to 127.0.0.1
[2016-09-05 18:56:49.268] [8328] [info]    Received message from 127.0.0.1: PLAY 1-10 "BURBERRY/WWAW16-ONSITE-CAPTURE" CUT 1 Linear RIGHT SEEK 5300  LOOP\r\n
[2016-09-05 18:56:49.311] [8040] [debug]   ffmpeg_input[C:\Users\fotw\Videos\\BURBERRY\wwaw16-onsite-capture.mov)] Seeking: 5300
[2016-09-05 18:56:49.312] [8040] [info]    Initialized ffmpeg tbb context.
[2016-09-05 18:56:49.315] [8040] [info]    ffmpeg[wwaw16-onsite-capture.mov|1920x1080i50.00|0/29493] [video-decoder] ProRes
[2016-09-05 18:56:49.318] [8040] [debug]   [audio-decoder] PCM signed 24-bit little-endian Selected channel layout STEREO
[2016-09-05 18:56:49.318] [8040] [info]    ffmpeg[wwaw16-onsite-capture.mov|1920x1080i50.00|0/29493] [audio-decoder] PCM signed 24-bit little-endian
[2016-09-05 18:56:49.319] [8040] [info]    transition[empty=>ffmpeg[wwaw16-onsite-capture.mov|1920x1080i50.00|0/29493]] Initialized.
[2016-09-05 18:56:49.319] [8040] [debug]   Executed command: PlayCommand
[2016-09-05 18:56:49.320] [8040] [info]    Sent message to 127.0.0.1: 202 PLAY OK\r\n
[2016-09-05 18:56:49.324] [7992] [info]    transition[empty=>ffmpeg[wwaw16-onsite-capture.mov|1920x1080i50.00|0/29493]] End Of File.
[2016-09-05 18:56:49.339] [7992] [info]   
+---------------+
| filter_buffer |default--[1920x1080 0:1 yuv422p10le]--auto-inserted scaler 0:default
|   (buffer)    |
+---------------+

                                                                +-------------------+
auto-inserted scaler 0:default--[1920x1080 0:1 yuv422p]--default| filter_buffersink |
                                                                |   (buffersink)    |
                                                                +-------------------+

                                                           +------------------------+
filter_buffer:default--[1920x1080 0:1 yuv422p10le]--default| auto-inserted scaler 0 |default--[1920x1080 0:1 yuv422p]--filter_buffersink:default
                                                           |        (scale)         |
                                                           +------------------------+


[2016-09-05 18:56:49.339] [7992] [info]    [frame_muxer] simple 1920x1080p25.00
[2016-09-05 18:56:49.363] [7992] [info]    transition[empty=>ffmpeg[wwaw16-onsite-capture.mov|1920x1080p25.00|5301/29493]] Uninitialized.
[2016-09-05 18:57:30.588] [8328] [info]    Received message from 127.0.0.1: STOP 1-10\r\n
[2016-09-05 18:57:30.588] [8040] [debug]   Executed command: StopCommand
[2016-09-05 18:57:30.588] [8040] [info]    Sent message to 127.0.0.1: 202 STOP OK\r\n
[2016-09-05 18:57:30.589] [3464] [info]    Released ffmpeg tbb context.
[2016-09-05 18:57:40.301] [7372] [info]    Received message from Console: KILL\r\n
[2016-09-05 18:57:40.301] [8008] [debug]   Executed command: KillCommand
[2016-09-05 18:57:40.446] [7268] [info]    Screen consumer [1|1080i5000] Successfully Uninitialized.
[2016-09-05 18:57:40.479] [8016] [error]   UltraStudio Mini Monitor [1-1|1080i5000] Failed to schedule audio.
[2016-09-05 18:57:40.491] [8152] [info]    UltraStudio Mini Monitor [1-1|1080i5000] Scheduled playback has stopped.
[2016-09-05 18:57:40.559] [7988] [debug]   UltraStudio Mini Monitor [1-1|1080i5000] allocated a total of 24883200 bytes and was called 861 times during playout
[2016-09-05 18:57:40.559] [7268] [info]    UltraStudio Mini Monitor [1-1|1080i5000] Successfully Uninitialized.
[2016-09-05 18:57:40.612] [7268] [info]    Uninitialized html module.
[2016-09-05 18:57:41.113] [7268] [info]    Successfully shutdown CasparCG Server.
FlyOntheWall
 
Posts: 27
Joined: 16 Feb 2011, 17:28

Return to Help & Support

Who is online

Users browsing this forum: No registered users and 1 guest